cGit-UI for Git Repositories

cGit-UI – is a web interface for Git Repositories. cGit CGI script is writen in C and therefore it's fast enough

12 Commits   0 Branches   1 Tag
Index: PKGBUILD
===================================================================
--- PKGBUILD	(nonexistent)
+++ PKGBUILD	(revision 5)
@@ -0,0 +1,38 @@
+#
+# Maintainer: Andrey V.Kosteltsev <kx@radix.pro>
+#
+pkgname=cgit-ui
+pkgver=0.1.7
+pkgrel=2
+pkgdesc='cGit-ui CGI Script is a web interface for Git Repositories'
+arch=('x86_64')
+url='https://csvn.radix.pro'
+license=('custom')
+depends=('file' 'pcre2' 'libgit2' 'md4c')
+source=("https://ftp.radix.pro/pub/cgit-ui/${pkgname}-${pkgver}.tar.xz")
+md5sums=('..Check MD5 sum before Building Package..')
+
+build() {
+  cd ${pkgname}-${pkgver}
+
+  CFLAGS="-O2 -fPIC -Wno-unused-result" \
+  ./configure \
+    --prefix=/usr \
+    --sysconfdir=/etc \
+    --with-scriptdir=/usr/share/nginx/cgit
+
+  make
+}
+
+package() {
+  cd ${pkgname}-${pkgver}
+
+  make install DESTDIR="${pkgdir}"
+
+  # Gzip man pages:
+  gzip -9 ${pkgdir}/usr/share/man/man5/cgit-ui.rc.5
+
+  # Install documentation:
+  install -d ${pkgdir}/usr/share/doc/${pkgname}-${pkgver}
+  cp -a ChangeLog LICENSE README README.md doc/ ${pkgdir}/usr/share/doc/${pkgname}-${pkgver}
+}