cGit-UI for Git Repositories

cGit-UI – is a web interface for Git Repositories. cGit CGI script is writen in C and therefore it's fast enough

12 Commits   0 Branches   1 Tag
     5         kx #
     5         kx # Maintainer: Andrey V.Kosteltsev <kx@radix.pro>
     5         kx #
     5         kx pkgname=cgit-ui
     5         kx pkgver=0.1.7
     5         kx pkgrel=2
     5         kx pkgdesc='cGit-ui CGI Script is a web interface for Git Repositories'
     5         kx arch=('x86_64')
     5         kx url='https://csvn.radix.pro'
     5         kx license=('custom')
     5         kx depends=('file' 'pcre2' 'libgit2' 'md4c')
     5         kx source=("https://ftp.radix.pro/pub/cgit-ui/${pkgname}-${pkgver}.tar.xz")
     5         kx md5sums=('..Check MD5 sum before Building Package..')
     5         kx 
     5         kx build() {
     5         kx   cd ${pkgname}-${pkgver}
     5         kx 
     5         kx   CFLAGS="-O2 -fPIC -Wno-unused-result" \
     5         kx   ./configure \
     5         kx     --prefix=/usr \
     5         kx     --sysconfdir=/etc \
     5         kx     --with-scriptdir=/usr/share/nginx/cgit
     5         kx 
     5         kx   make
     5         kx }
     5         kx 
     5         kx package() {
     5         kx   cd ${pkgname}-${pkgver}
     5         kx 
     5         kx   make install DESTDIR="${pkgdir}"
     5         kx 
     5         kx   # Gzip man pages:
     5         kx   gzip -9 ${pkgdir}/usr/share/man/man5/cgit-ui.rc.5
     5         kx 
     5         kx   # Install documentation:
     5         kx   install -d ${pkgdir}/usr/share/doc/${pkgname}-${pkgver}
     5         kx   cp -a ChangeLog LICENSE README README.md doc/ ${pkgdir}/usr/share/doc/${pkgname}-${pkgver}
     5         kx }