Platform

The main Radix cross Linux repository contains build scripts of the GNU/Linux distribution.

906 Commits   6 Branches   3 Tags   |
Index: radix-1.8/dev/guile/3.0.5/Makefile
===================================================================
--- radix-1.8/dev/guile/3.0.5/Makefile	(revision 900)
+++ radix-1.8/dev/guile/3.0.5/Makefile	(revision 901)
@@ -54,7 +54,7 @@
 
 SOURCE_REQUIRES    = sources/GNU/guile
 
-REQUIRES           = libs/libffi/3.3
+REQUIRES           = libs/libffi/3.4.2
 REQUIRES          += libs/gmp/6.2.1
 REQUIRES          += libs/readline/8.1
 REQUIRES          += dev/libtool/2.4.6
Index: radix-1.8/dev/guile/3.0.5-ppc32/Makefile
===================================================================
--- radix-1.8/dev/guile/3.0.5-ppc32/Makefile	(revision 900)
+++ radix-1.8/dev/guile/3.0.5-ppc32/Makefile	(revision 901)
@@ -16,7 +16,7 @@
 SOURCE_REQUIRES    = sources/GNU/guile
 
 REQUIRES           = dev/guile/3.0.5
-REQUIRES          += libs/libffi/3.3-ppc32
+REQUIRES          += libs/libffi/3.4.2-ppc32
 REQUIRES          += libs/gmp/6.2.1-ppc32
 REQUIRES          += libs/readline/8.1-ppc32
 REQUIRES          += dev/libtool/2.4.6-ppc32
Index: radix-1.8/dev/guile/3.0.5-x86_32/Makefile
===================================================================
--- radix-1.8/dev/guile/3.0.5-x86_32/Makefile	(revision 900)
+++ radix-1.8/dev/guile/3.0.5-x86_32/Makefile	(revision 901)
@@ -13,7 +13,7 @@
 SOURCE_REQUIRES    = sources/GNU/guile
 
 REQUIRES           = dev/guile/3.0.5
-REQUIRES          += libs/libffi/3.3-x86_32
+REQUIRES          += libs/libffi/3.4.2-x86_32
 REQUIRES          += libs/gmp/6.2.1-x86_32
 REQUIRES          += libs/readline/8.1-x86_32
 REQUIRES          += dev/libtool/2.4.6-x86_32
Index: radix-1.8/dev/llvm/11.1.0/Makefile
===================================================================
--- radix-1.8/dev/llvm/11.1.0/Makefile	(revision 900)
+++ radix-1.8/dev/llvm/11.1.0/Makefile	(revision 901)
@@ -55,7 +55,7 @@
 SOURCE_REQUIRES    = sources/packages/d/llvm
 
 REQUIRES           = dev/gcc/11.2.0
-REQUIRES          += libs/libffi/3.3
+REQUIRES          += libs/libffi/3.4.2
 REQUIRES          += libs/elfutils/0.182
 REQUIRES          += libs/libxml2/2.9.9
 REQUIRES          += libs/libedit/20191231-3.1
Index: radix-1.8/dev/llvm/11.1.0-ppc32/Makefile
===================================================================
--- radix-1.8/dev/llvm/11.1.0-ppc32/Makefile	(revision 900)
+++ radix-1.8/dev/llvm/11.1.0-ppc32/Makefile	(revision 901)
@@ -16,7 +16,7 @@
 SOURCE_REQUIRES    = sources/packages/d/llvm
 
 REQUIRES           = dev/llvm/11.1.0
-REQUIRES          += libs/libffi/3.3-ppc32
+REQUIRES          += libs/libffi/3.4.2-ppc32
 REQUIRES          += libs/elfutils/0.182-ppc32
 REQUIRES          += libs/libxml2/2.9.9-ppc32
 REQUIRES          += libs/libedit/20191231-3.1-ppc32
Index: radix-1.8/dev/llvm/11.1.0-x86_32/Makefile
===================================================================
--- radix-1.8/dev/llvm/11.1.0-x86_32/Makefile	(revision 900)
+++ radix-1.8/dev/llvm/11.1.0-x86_32/Makefile	(revision 901)
@@ -13,7 +13,7 @@
 SOURCE_REQUIRES    = sources/packages/d/llvm
 
 REQUIRES           = dev/llvm/11.1.0
-REQUIRES          += libs/libffi/3.3-x86_32
+REQUIRES          += libs/libffi/3.4.2-x86_32
 REQUIRES          += libs/elfutils/0.182-x86_32
 REQUIRES          += libs/libxml2/2.9.9-x86_32
 REQUIRES          += libs/libedit/20191231-3.1-x86_32
Index: radix-1.8/dev/python2/2.7.18/Makefile
===================================================================
--- radix-1.8/dev/python2/2.7.18/Makefile	(revision 900)
+++ radix-1.8/dev/python2/2.7.18/Makefile	(revision 901)
@@ -57,7 +57,7 @@
 
 REQUIRES           = libs/zlib/1.2.11
 REQUIRES          += app/xz/5.2.5
-REQUIRES          += libs/libffi/3.3
+REQUIRES          += libs/libffi/3.4.2
 REQUIRES          += libs/readline/8.1
 REQUIRES          += libs/expat/2.2.10
 REQUIRES          += net/openssl/1.1.1l
Index: radix-1.8/dev/python2/2.7.18-ppc32/Makefile
===================================================================
--- radix-1.8/dev/python2/2.7.18-ppc32/Makefile	(revision 900)
+++ radix-1.8/dev/python2/2.7.18-ppc32/Makefile	(revision 901)
@@ -18,7 +18,7 @@
 REQUIRES           = dev/python2/2.7.18
 REQUIRES          += libs/zlib/1.2.11-ppc32
 REQUIRES          += app/xz/5.2.5-ppc32
-REQUIRES          += libs/libffi/3.3-ppc32
+REQUIRES          += libs/libffi/3.4.2-ppc32
 REQUIRES          += libs/readline/8.1-ppc32
 REQUIRES          += libs/expat/2.2.10-ppc32
 REQUIRES          += net/openssl/1.1.1l-ppc32
Index: radix-1.8/dev/python2/2.7.18-x86_32/Makefile
===================================================================
--- radix-1.8/dev/python2/2.7.18-x86_32/Makefile	(revision 900)
+++ radix-1.8/dev/python2/2.7.18-x86_32/Makefile	(revision 901)
@@ -15,7 +15,7 @@
 REQUIRES           = dev/python2/2.7.18
 REQUIRES          += libs/zlib/1.2.11-x86_32
 REQUIRES          += app/xz/5.2.5-x86_32
-REQUIRES          += libs/libffi/3.3-x86_32
+REQUIRES          += libs/libffi/3.4.2-x86_32
 REQUIRES          += libs/readline/8.1-x86_32
 REQUIRES          += libs/expat/2.2.10-x86_32
 REQUIRES          += net/openssl/1.1.1l-x86_32
Index: radix-1.8/dev/python3/3.9.9/Makefile
===================================================================
--- radix-1.8/dev/python3/3.9.9/Makefile	(revision 900)
+++ radix-1.8/dev/python3/3.9.9/Makefile	(revision 901)
@@ -59,7 +59,7 @@
 REQUIRES          += app/xz/5.2.5
 REQUIRES          += app/bzip2/1.0.8
 REQUIRES          += app/sqlite/3.34.0.0
-REQUIRES          += libs/libffi/3.3
+REQUIRES          += libs/libffi/3.4.2
 REQUIRES          += libs/expat/2.2.10
 REQUIRES          += libs/gdbm/1.19
 REQUIRES          += net/openssl/1.1.1l
Index: radix-1.8/dev/python3/3.9.9-ppc32/Makefile
===================================================================
--- radix-1.8/dev/python3/3.9.9-ppc32/Makefile	(revision 900)
+++ radix-1.8/dev/python3/3.9.9-ppc32/Makefile	(revision 901)
@@ -20,7 +20,7 @@
 REQUIRES          += app/xz/5.2.5-ppc32
 REQUIRES          += app/bzip2/1.0.8-ppc32
 REQUIRES          += app/sqlite/3.34.0.0-ppc32
-REQUIRES          += libs/libffi/3.3-ppc32
+REQUIRES          += libs/libffi/3.4.2-ppc32
 REQUIRES          += libs/expat/2.2.10-ppc32
 REQUIRES          += libs/gdbm/1.19-ppc32
 REQUIRES          += net/openssl/1.1.1l-ppc32
Index: radix-1.8/dev/python3/3.9.9-x86_32/Makefile
===================================================================
--- radix-1.8/dev/python3/3.9.9-x86_32/Makefile	(revision 900)
+++ radix-1.8/dev/python3/3.9.9-x86_32/Makefile	(revision 901)
@@ -17,7 +17,7 @@
 REQUIRES          += app/xz/5.2.5-x86_32
 REQUIRES          += app/bzip2/1.0.8-x86_32
 REQUIRES          += app/sqlite/3.34.0.0-x86_32
-REQUIRES          += libs/libffi/3.3-x86_32
+REQUIRES          += libs/libffi/3.4.2-x86_32
 REQUIRES          += libs/expat/2.2.10-x86_32
 REQUIRES          += libs/gdbm/1.19-x86_32
 REQUIRES          += net/openssl/1.1.1l-x86_32
Index: radix-1.8/libs/glib2/2.70.1/Makefile
===================================================================
--- radix-1.8/libs/glib2/2.70.1/Makefile	(revision 900)
+++ radix-1.8/libs/glib2/2.70.1/Makefile	(revision 901)
@@ -54,7 +54,7 @@
 
 SOURCE_REQUIRES    = sources/GNOME/core/glib2
 
-REQUIRES           = libs/libffi/3.3
+REQUIRES           = libs/libffi/3.4.2
 REQUIRES          += libs/elfutils/0.182
 REQUIRES          += libs/pcre/8.44
 REQUIRES          += app/attr/2.4.48
Index: radix-1.8/libs/glib2/2.70.1-ppc32/Makefile
===================================================================
--- radix-1.8/libs/glib2/2.70.1-ppc32/Makefile	(revision 900)
+++ radix-1.8/libs/glib2/2.70.1-ppc32/Makefile	(revision 901)
@@ -16,7 +16,7 @@
 SOURCE_REQUIRES    = sources/GNOME/core/glib2
 
 REQUIRES           = libs/glib2/2.70.1
-REQUIRES          += libs/libffi/3.3-ppc32
+REQUIRES          += libs/libffi/3.4.2-ppc32
 REQUIRES          += libs/elfutils/0.182-ppc32
 REQUIRES          += libs/pcre/8.44-ppc32
 REQUIRES          += app/attr/2.4.48-ppc32
Index: radix-1.8/libs/glib2/2.70.1-x86_32/Makefile
===================================================================
--- radix-1.8/libs/glib2/2.70.1-x86_32/Makefile	(revision 900)
+++ radix-1.8/libs/glib2/2.70.1-x86_32/Makefile	(revision 901)
@@ -13,7 +13,7 @@
 SOURCE_REQUIRES    = sources/GNOME/core/glib2
 
 REQUIRES           = libs/glib2/2.70.1
-REQUIRES          += libs/libffi/3.3-x86_32
+REQUIRES          += libs/libffi/3.4.2-x86_32
 REQUIRES          += libs/elfutils/0.182-x86_32
 REQUIRES          += libs/pcre/8.44-x86_32
 REQUIRES          += app/attr/2.4.48-x86_32
Index: radix-1.8/libs/libffi/3.3/libffi-pkg-description.in
===================================================================
--- radix-1.8/libs/libffi/3.3/libffi-pkg-description.in	(revision 900)
+++ radix-1.8/libs/libffi/3.3/libffi-pkg-description.in	(nonexistent)
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.  Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in.  You must
-# make exactly 11 lines for the formatting to be correct.  It's also
-# customary to leave one space after the ':'.
-
-      |-----handy-ruler------------------------------------------------------|
-libffi: libffi @VERSION@ (A Portable Foreign Function Interface Library)
-libffi:
-libffi: FFI stands for Foreign Function Interface.  A foreign function
-libffi: interface is the popular name for the interface that allows code
-libffi: written in one language to call code written in another language.
-libffi: The libffi library really only provides the lowest, machine
-libffi: dependent layer of a fully featured foreign function interface.
-libffi:
-libffi: Homepage: http://sourceware.org/libffi/
-libffi:
-libffi:
Index: radix-1.8/libs/libffi/3.3/libffi-pkg-install.sh
===================================================================
--- radix-1.8/libs/libffi/3.3/libffi-pkg-install.sh	(revision 900)
+++ radix-1.8/libs/libffi/3.3/libffi-pkg-install.sh	(nonexistent)
@@ -1,69 +0,0 @@
-#!/bin/sh
-
-# Preserve new files
-install_file() {
-  NEW="$1"
-  OLD="`dirname $NEW`/`basename $NEW .new`"
-  # If there's no file by that name, mv it over:
-  if [ ! -r $OLD ]; then
-    mv $NEW $OLD
-  elif [ "`cat $OLD | md5sum`" = "`cat $NEW | md5sum`" ]; then # toss the redundant copy
-    rm $NEW
-  fi
-  # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-
-# arg 1:  the new package version
-pre_install() {
-  /bin/true
-}
-
-# arg 1:  the new package version
-post_install() {
-  #
-  # NOTE:
-  #   'install-info' can work using relative paths and we can make use build machine
-  #   utility during installation to the some partition and use target 'install-info'
-  #   during installation directly on the running target machine.
-  #
-  if [ -x /usr/bin/install-info ] ; then
-    install-info --info-dir=usr/share/info usr/share/info/libffi.info.gz  2>/dev/null
-  elif ! grep "(libffi)" usr/share/info/dir 1> /dev/null 2> /dev/null ; then
-  cat << EOF >> usr/share/info/dir
-
-Development
-* libffi: (libffi).             Portable foreign function interface library.
-EOF
-  fi
-}
-
-# arg 1:  the new package version
-# arg 2:  the old package version
-pre_update() {
-  /bin/true
-}
-
-# arg 1:  the new package version
-# arg 2:  the old package version
-post_update() {
-  post_install
-}
-
-# arg 1:  the old package version
-pre_remove() {
-  if [ -x /usr/bin/install-info ] ; then
-    install-info --delete --info-file=usr/share/info/libffi.info.gz --dir-file=usr/share/info/dir 2> /dev/null || /bin/true
-  fi
-}
-
-# arg 1:  the old package version
-post_remove() {
-  /bin/true
-}
-
-
-operation=$1
-shift
-
-$operation $*

Property changes on: radix-1.8/libs/libffi/3.3/libffi-pkg-install.sh
___________________________________________________________________
Deleted: svn:executable
## -1 +0,0 ##
-*
\ No newline at end of property
Index: radix-1.8/libs/libffi/3.3/Makefile
===================================================================
--- radix-1.8/libs/libffi/3.3/Makefile	(revision 900)
+++ radix-1.8/libs/libffi/3.3/Makefile	(nonexistent)
@@ -1,235 +0,0 @@
-
-COMPONENT_TARGETS  = $(HARDWARE_INTEL_PC32)
-COMPONENT_TARGETS += $(HARDWARE_INTEL_PC64)
-COMPONENT_TARGETS += $(HARDWARE_EBOX_3350DX2)
-COMPONENT_TARGETS += $(HARDWARE_CB1X)
-COMPONENT_TARGETS += $(HARDWARE_CB2X)
-COMPONENT_TARGETS += $(HARDWARE_CB3X)
-COMPONENT_TARGETS += $(HARDWARE_ORANGE_PP2E)
-COMPONENT_TARGETS += $(HARDWARE_NANOPI_NEO)
-COMPONENT_TARGETS += $(HARDWARE_ORANGE_PP)
-COMPONENT_TARGETS += $(HARDWARE_ORANGE_PL2)
-COMPONENT_TARGETS += $(HARDWARE_WECHIP_TX6)
-COMPONENT_TARGETS += $(HARDWARE_FFRK3288)
-COMPONENT_TARGETS += $(HARDWARE_POIN2)
-COMPONENT_TARGETS += $(HARDWARE_RK3328_CC)
-COMPONENT_TARGETS += $(HARDWARE_KHADAS_EDGE)
-COMPONENT_TARGETS += $(HARDWARE_LEEZ_P710)
-COMPONENT_TARGETS += $(HARDWARE_M201)
-COMPONENT_TARGETS += $(HARDWARE_MXV)
-COMPONENT_TARGETS += $(HARDWARE_P201)
-COMPONENT_TARGETS += $(HARDWARE_NEXBOX_A95X)
-COMPONENT_TARGETS += $(HARDWARE_ODROID_C2)
-COMPONENT_TARGETS += $(HARDWARE_P212)
-COMPONENT_TARGETS += $(HARDWARE_KHADAS_VIM)
-COMPONENT_TARGETS += $(HARDWARE_Q201)
-COMPONENT_TARGETS += $(HARDWARE_ENYBOX_X2)
-COMPONENT_TARGETS += $(HARDWARE_KHADAS_VIM2)
-COMPONENT_TARGETS += $(HARDWARE_NIT6Q)
-COMPONENT_TARGETS += $(HARDWARE_OKMX6DL_C)
-COMPONENT_TARGETS += $(HARDWARE_OKMX6Q_C)
-COMPONENT_TARGETS += $(HARDWARE_BONE_BLACK)
-COMPONENT_TARGETS += $(HARDWARE_OMAP5UEVM)
-COMPONENT_TARGETS += $(HARDWARE_DRA7XXEVM)
-COMPONENT_TARGETS += $(HARDWARE_CI20)
-COMPONENT_TARGETS += $(HARDWARE_BAIKAL_T1)
-COMPONENT_TARGETS += $(HARDWARE_BAIKAL_M1)
-COMPONENT_TARGETS += $(HARDWARE_S824L)
-COMPONENT_TARGETS += $(HARDWARE_VESNIN)
-COMPONENT_TARGETS += $(HARDWARE_S824L_LSB)
-COMPONENT_TARGETS += $(HARDWARE_VESNIN_LSB)
-COMPONENT_TARGETS += $(HARDWARE_TL2WK2)
-COMPONENT_TARGETS += $(HARDWARE_TL2SV2)
-COMPONENT_TARGETS += $(HARDWARE_TL2WK2_LSB)
-COMPONENT_TARGETS += $(HARDWARE_TL2SV2_LSB)
-COMPONENT_TARGETS += $(HARDWARE_SIFIVE_U740)
-
-
-NEED_ABS_PATH      = true
-COMPONENT_IS_3PP   = true
-
-
-include ../../../build-system/constants.mk
-
-
-SOURCE_REQUIRES    = sources/packages/l/libffi
-
-ifeq ($(__USE_BUILT_GCC_LIBS__),yes)
-REQUIRES           = dev/gcc/11.2.0
-else
-REQUIRES           = libs/glibc/2.34
-endif
-
-# ======= __END_OF_REQUIRES__ =======
-
-
-version            = 3.3
-tar_gz_archive     = $(SRC_PACKAGE_PATH)/packages/l/libffi/libffi-$(version).tar.gz
-SRC_ARCHIVE        = $(tar_gz_archive)
-SRC_DIR            = $(TARGET_BUILD_DIR)/libffi-$(version)
-src_dir_name       = libffi-$(version)
-src_done           = $(TARGET_BUILD_DIR)/.source_done
-
-PATCHES = PATCHES
-
-build_dir          = $(TARGET_BUILD_DIR)/build
-build_target       = $(TARGET_BUILD_DIR)/.build_done
-install_target     = $(TARGET_BUILD_DIR)/.install_done
-
-
-####### Targets
-
-PKG_GROUP = libs
-
-#
-# *PKG_NAME & *PKG_VERSION shouldn't be a reference to value.
-#
-LIBFFI_PKG_NAME                = libffi
-LIBFFI_PKG_VERSION             = 3.3
-LIBFFI_PKG_ARCH                = $(TOOLCHAIN)
-LIBFFI_PKG_DISTRO_NAME         = $(DISTRO_NAME)
-LIBFFI_PKG_DISTRO_VERSION      = $(DISTRO_VERSION)
-LIBFFI_PKG_GROUP               = $(PKG_GROUP)
-###                             |---handy-ruler-------------------------------|
-LIBFFI_PKG_SHORT_DESCRIPTION   = Portable Foreign Function Interface Library
-LIBFFI_PKG_URL                 = $(BUG_URL)
-LIBFFI_PKG_LICENSE             = GPLv2
-LIBFFI_PKG_DESCRIPTION_FILE    = $(TARGET_BUILD_DIR)/$(LIBFFI_PKG_NAME)-pkg-description
-LIBFFI_PKG_DESCRIPTION_FILE_IN = $(LIBFFI_PKG_NAME)-pkg-description.in
-LIBFFI_PKG_INSTALL_SCRIPT      = $(LIBFFI_PKG_NAME)-pkg-install.sh
-
-LIBFFI_PKG       = $(CURDIR)/$(TARGET_BUILD_DIR)/$(LIBFFI_PKG_NAME)-package
-
-pkg_basename     = $(LIBFFI_PKG_NAME)-$(LIBFFI_PKG_VERSION)-$(LIBFFI_PKG_ARCH)-$(LIBFFI_PKG_DISTRO_NAME)-$(LIBFFI_PKG_DISTRO_VERSION)
-
-pkg_archive      = $(TARGET_BUILD_DIR)/$(PKG_GROUP)/$(pkg_basename).$(pkg_arch_suffix)
-pkg_certificate  = $(call cert-name,$(pkg_archive))
-pkg_signature    = $(call sign-name,$(pkg_archive))
-pkg_description  = $(call desc-name,$(pkg_archive))
-products         = $(call pkg-files,$(pkg_archive))
-
-BUILD_TARGETS    = $(build_target)
-BUILD_TARGETS   += $(install_target)
-
-PRODUCT_TARGETS  = $(products)
-
-ROOTFS_TARGETS   = $(pkg_archive)
-
-
-include ../../../build-system/core.mk
-
-
-env_sysroot = DESTDIR=$(LIBFFI_PKG)
-
-
-extra_configure_switches  = --libdir=/usr/lib$(LIBSUFFIX)
-extra_configure_switches += --docdir=/usr/share/doc/$(src_dir_name)
-extra_configure_switches += --mandir=/usr/share/man
-extra_configure_switches += --disable-dependency-tracking
-extra_configure_switches += --sysconfdir=/etc
-extra_configure_switches += --localstatedir=/var
-ifeq ($(__ENABLE_STATIC__),yes)
-extra_configure_switches += --enable-static=yes
-else
-extra_configure_switches += --enable-static=no
-endif
-extra_configure_switches += --enable-shared=yes
-
-
-####### Dependencies
-
-$(src_done): $(SRC_ARCHIVE) $(PATCHES_DEP)
-	$(UNPACK_SRC_ARCHIVE)
-	$(APPLY_PATCHES)
-	@touch $@
-
-$(build_target): $(src_done)
-	@mkdir -p $(build_dir)
-	@cd $(build_dir) && \
-	  $(BUILD_ENVIRONMENT) ../$(src_dir_name)/configure \
-	  --prefix=/usr               \
-	  --build=$(BUILD)            \
-	  --host=$(TARGET)            \
-	  $(extra_configure_switches)
-	@cd $(build_dir) && $(BUILD_ENVIRONMENT) $(MAKE)
-	@touch $@
-
-$(install_target): $(build_target)
-	@mkdir -p $(LIBFFI_PKG)
-	@cd $(build_dir) && $(BUILD_ENVIRONMENT) $(MAKE) -j1 install $(env_sysroot)
-	# ======= Install Documentation =======
-	@rm -f $(LIBFFI_PKG)/usr/share/info/dir
-	@gzip -9 $(LIBFFI_PKG)/usr/share/info/*
-	@if [ -d $(LIBFFI_PKG)/usr/share/man ]; then \
-	  ( cd $(LIBFFI_PKG)/usr/share/man ; \
-	    for manpagedir in `find . -type d -name "man*"` ; do \
-	      ( cd $$manpagedir ; \
-	        for eachpage in `find . -type l -maxdepth 1` ; do \
-	          ln -s `readlink $$eachpage`.gz $$eachpage.gz ; \
-	          rm $$eachpage ; \
-	        done ; \
-	        gzip -9 *.?  ; \
-	      ) \
-	    done \
-	  ) \
-	 fi
-	@mkdir -p $(LIBFFI_PKG)/usr/doc/$(src_dir_name)
-	@cp -a $(SRC_DIR)/LICENSE* $(SRC_DIR)/README* $(SRC_DIR)/doc/libffi.pdf \
-	       $(LIBFFI_PKG)/usr/doc/$(src_dir_name)
-	@( cd $(SRC_DIR) ; \
-	   if [ -r ChangeLog ]; then \
-	     DOCSDIR=`echo $(LIBFFI_PKG)/usr/doc/$(src_dir_name)` ; \
-	     cat ChangeLog | head -n 1000 > $$DOCSDIR/ChangeLog ; \
-	     touch -r ChangeLog $$DOCSDIR/ChangeLog ; \
-	   fi \
-	 )
-	# ======= remove toolchain path from target libtool *.la files =======
-	@( cd $(LIBFFI_PKG)/usr/lib$(LIBSUFFIX) ; \
-	   sed -i "s,$(TARGET_DEST_DIR),,g" libffi.la  \
-	 )
-	# ======= Install the same to $(TARGET_DEST_DIR) =======
-	$(call install-into-devenv, $(LIBFFI_PKG))
-	# ======= tune libtool *.la search path to the target destination for development =======
-	@( cd $(TARGET_DEST_DIR)/usr/lib$(LIBSUFFIX) ; \
-	   sed -i "s,/usr,$(TARGET_DEST_DIR)/usr,g" libffi.la ; \
-	   sed -i "s,L/lib,L$(TARGET_DEST_DIR)/lib,g" libffi.la \
-	 )
-	# ======= tune pkg-config *.pc search path to the target destination for development =======
-	@( cd $(TARGET_DEST_DIR)/usr/lib$(LIBSUFFIX)/pkgconfig ; \
-	   sed -i "s,/usr,$(TARGET_DEST_DIR)/usr,g" libffi.pc \
-	 )
-	# ======= Strip binaries =======
-	@( cd $(LIBFFI_PKG) ; \
-	   find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs $(STRIP) --strip-unneeded 2> /dev/null ; \
-	   find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs $(STRIP) --strip-unneeded 2> /dev/null ; \
-	 )
-ifeq ($(__ENABLE_STATIC__),yes)
-	@( cd $(LIBFFI_PKG) ; \
-	   find . | xargs file | grep "current ar archive" | cut -f 1 -d : | xargs $(STRIP) -g 2> /dev/null ; \
-	 )
-endif
-	@touch $@
-
-$(LIBFFI_PKG_DESCRIPTION_FILE): $(LIBFFI_PKG_DESCRIPTION_FILE_IN)
-	@cat $< | $(SED) -e "s/@VERSION@/$(version)/g" > $@
-
-$(pkg_certificate) : $(pkg_archive) ;
-$(pkg_signature)   : $(pkg_archive) ;
-$(pkg_description) : $(pkg_archive) ;
-
-$(pkg_archive): $(install_target) $(LIBFFI_PKG_DESCRIPTION_FILE) $(LIBFFI_PKG_INSTALL_SCRIPT)
-	@cp $(LIBFFI_PKG_DESCRIPTION_FILE) $(LIBFFI_PKG)/.DESCRIPTION
-	@cp $(LIBFFI_PKG_INSTALL_SCRIPT) $(LIBFFI_PKG)/.INSTALL
-	@$(BUILD_PKG_REQUIRES) $(LIBFFI_PKG)/.REQUIRES
-	@echo "pkgname=$(LIBFFI_PKG_NAME)"                            >  $(LIBFFI_PKG)/.PKGINFO ; \
-	 echo "pkgver=$(LIBFFI_PKG_VERSION)"                          >> $(LIBFFI_PKG)/.PKGINFO ; \
-	 echo "arch=$(LIBFFI_PKG_ARCH)"                               >> $(LIBFFI_PKG)/.PKGINFO ; \
-	 echo "distroname=$(LIBFFI_PKG_DISTRO_NAME)"                  >> $(LIBFFI_PKG)/.PKGINFO ; \
-	 echo "distrover=$(LIBFFI_PKG_DISTRO_VERSION)"                >> $(LIBFFI_PKG)/.PKGINFO ; \
-	 echo "group=$(LIBFFI_PKG_GROUP)"                             >> $(LIBFFI_PKG)/.PKGINFO ; \
-	 echo "short_description=\"$(LIBFFI_PKG_SHORT_DESCRIPTION)\"" >> $(LIBFFI_PKG)/.PKGINFO ; \
-	 echo "url=$(LIBFFI_PKG_URL)"                                 >> $(LIBFFI_PKG)/.PKGINFO ; \
-	 echo "license=$(LIBFFI_PKG_LICENSE)"                         >> $(LIBFFI_PKG)/.PKGINFO
-	@$(PSEUDO) sh -c "cd $(LIBFFI_PKG) && \
-	                  chown -R root:root . && \
-	                  $(MAKE_PACKAGE) -J --linkadd=yes $(GNUPG_OPTIONS) -m -d .. ."
Index: radix-1.8/libs/libffi/3.3
===================================================================
--- radix-1.8/libs/libffi/3.3	(revision 900)
+++ radix-1.8/libs/libffi/3.3	(nonexistent)

Property changes on: radix-1.8/libs/libffi/3.3
___________________________________________________________________
Deleted: svn:ignore
## -1,73 +0,0 ##
-
-# install dir
-dist
-
-# Target build dirs
-.a1x-newlib
-.a2x-newlib
-.at91sam7s-newlib
-
-.build-machine
-
-.a1x-glibc
-.a2x-glibc
-.h3-glibc
-.h5-glibc
-.i586-glibc
-.i686-glibc
-.imx6-glibc
-.jz47xx-glibc
-.makefile
-.am335x-glibc
-.omap543x-glibc
-.p5600-glibc
-.power8-glibc
-.power8le-glibc
-.power9-glibc
-.power9le-glibc
-.m1000-glibc
-.riscv64-glibc
-.rk328x-glibc
-.rk33xx-glibc
-.rk339x-glibc
-.s8xx-glibc
-.s9xx-glibc
-.x86_64-glibc
-
-# Hidden files (each file)
-.makefile
-.dist
-.rootfs
-
-# src & hw requires
-.src_requires
-.src_requires_depend
-.requires
-.requires_depend
-
-# Tarballs
-*.gz
-*.bz2
-*.lz
-*.xz
-*.tgz
-*.txz
-
-# Signatures
-*.asc
-*.sig
-*.sign
-*.sha1sum
-
-# Patches
-*.patch
-
-# Descriptions
-*.dsc
-*.txt
-
-# Default linux config files
-*.defconfig
-
-# backup copies
-*~
Index: radix-1.8/libs/libffi/3.3-x86_32/libffi-x32-pkg-description.in
===================================================================
--- radix-1.8/libs/libffi/3.3-x86_32/libffi-x32-pkg-description.in	(revision 900)
+++ radix-1.8/libs/libffi/3.3-x86_32/libffi-x32-pkg-description.in	(nonexistent)
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.  Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in.  You must
-# make exactly 11 lines for the formatting to be correct.  It's also
-# customary to leave one space after the ':'.
-
-          |-----handy-ruler------------------------------------------------------|
-libffi-x32: libffi-x32 @VERSION@ (A Portable Foreign Function Interface Lib)
-libffi-x32:
-libffi-x32: FFI stands for Foreign Function Interface.  A foreign function
-libffi-x32: interface is the popular name for the interface that allows code
-libffi-x32: written in one language to call code written in another language.
-libffi-x32: The libffi library really only provides the lowest, machine
-libffi-x32: dependent layer of a fully featured foreign function interface.
-libffi-x32:
-libffi-x32: Homepage: http://sourceware.org/libffi/
-libffi-x32:
-libffi-x32:
Index: radix-1.8/libs/libffi/3.3-x86_32/libffi-x32-pkg-install.sh
===================================================================
--- radix-1.8/libs/libffi/3.3-x86_32/libffi-x32-pkg-install.sh	(revision 900)
+++ radix-1.8/libs/libffi/3.3-x86_32/libffi-x32-pkg-install.sh	(nonexistent)
@@ -1,39 +0,0 @@
-#!/bin/sh
-
-# arg 1:  the new package version
-pre_install() {
-  /bin/true
-}
-
-# arg 1:  the new package version
-post_install() {
-  /bin/true
-}
-
-# arg 1:  the new package version
-# arg 2:  the old package version
-pre_update() {
-  /bin/true
-}
-
-# arg 1:  the new package version
-# arg 2:  the old package version
-post_update() {
-  post_install
-}
-
-# arg 1:  the old package version
-pre_remove() {
-  /bin/true
-}
-
-# arg 1:  the old package version
-post_remove() {
-  /bin/true
-}
-
-
-operation=$1
-shift
-
-$operation $*

Property changes on: radix-1.8/libs/libffi/3.3-x86_32/libffi-x32-pkg-install.sh
___________________________________________________________________
Deleted: svn:executable
## -1 +0,0 ##
-*
\ No newline at end of property
Index: radix-1.8/libs/libffi/3.3-x86_32/Makefile
===================================================================
--- radix-1.8/libs/libffi/3.3-x86_32/Makefile	(revision 900)
+++ radix-1.8/libs/libffi/3.3-x86_32/Makefile	(nonexistent)
@@ -1,164 +0,0 @@
-
-COMPONENT_TARGETS  = $(HARDWARE_INTEL_PC64)
-
-NEED_ABS_PATH      = true
-COMPONENT_IS_3PP   = true
-
-CREATE_X86_32_PACKAGE = true
-
-
-include ../../../build-system/constants.mk
-
-
-SOURCE_REQUIRES    = sources/packages/l/libffi
-
-REQUIRES           = libs/libffi/3.3
-REQUIRES          += libs/glibc/2.34-x86_32
-
-# ======= __END_OF_REQUIRES__ =======
-
-
-version            = 3.3
-tar_gz_archive     = $(SRC_PACKAGE_PATH)/packages/l/libffi/libffi-$(version).tar.gz
-SRC_ARCHIVE        = $(tar_gz_archive)
-SRC_DIR            = $(TARGET_BUILD_DIR)/libffi-$(version)
-src_dir_name       = libffi-$(version)
-src_done           = $(TARGET_BUILD_DIR)/.source_done
-
-PATCHES = PATCHES
-
-build_dir          = $(TARGET_BUILD_DIR)/build
-build_target       = $(TARGET_BUILD_DIR)/.build_done
-install_target     = $(TARGET_BUILD_DIR)/.install_done
-
-
-####### Targets
-
-PKG_GROUP = libs
-#
-# *PKG_NAME & *PKG_VERSION shouldn't be a reference to value.
-#
-LIBFFI32_PKG_NAME                = libffi-x32
-LIBFFI32_PKG_VERSION             = 3.3
-LIBFFI32_PKG_ARCH                = $(TOOLCHAIN)
-LIBFFI32_PKG_DISTRO_NAME         = $(DISTRO_NAME)
-LIBFFI32_PKG_DISTRO_VERSION      = $(DISTRO_VERSION)
-LIBFFI32_PKG_GROUP               = $(PKG_GROUP)
-###                               |---handy-ruler-------------------------------|
-LIBFFI32_PKG_SHORT_DESCRIPTION   = Portable Foreign Function Interface Library
-LIBFFI32_PKG_URL                 = $(BUG_URL)
-LIBFFI32_PKG_LICENSE             = GPLv2
-LIBFFI32_PKG_DESCRIPTION_FILE    = $(TARGET_BUILD_DIR)/$(LIBFFI32_PKG_NAME)-pkg-description
-LIBFFI32_PKG_DESCRIPTION_FILE_IN = $(LIBFFI32_PKG_NAME)-pkg-description.in
-LIBFFI32_PKG_INSTALL_SCRIPT      = $(LIBFFI32_PKG_NAME)-pkg-install.sh
-
-LIBFFI32_PKG     = $(CURDIR)/$(TARGET_BUILD_DIR)/$(LIBFFI32_PKG_NAME)-package
-
-pkg_basename     = $(LIBFFI32_PKG_NAME)-$(LIBFFI32_PKG_VERSION)-$(LIBFFI32_PKG_ARCH)-$(LIBFFI32_PKG_DISTRO_NAME)-$(LIBFFI32_PKG_DISTRO_VERSION)
-
-pkg_archive      = $(TARGET_BUILD_DIR)/$(PKG_GROUP)/$(pkg_basename).$(pkg_arch_suffix)
-pkg_certificate  = $(call cert-name,$(pkg_archive))
-pkg_signature    = $(call sign-name,$(pkg_archive))
-pkg_description  = $(call desc-name,$(pkg_archive))
-products         = $(call pkg-files,$(pkg_archive))
-
-BUILD_TARGETS    = $(build_target)
-BUILD_TARGETS   += $(install_target)
-
-PRODUCT_TARGETS  = $(products)
-
-ROOTFS_TARGETS   = $(pkg_archive)
-
-
-include ../../../build-system/core.mk
-
-
-env_sysroot  = DESTDIR=$(LIBFFI32_PKG)
-
-
-extra_configure_switches  = --libdir=/usr/lib$(MULTILIB_X86_32_SUFFIX)
-extra_configure_switches += --docdir=/usr/share/doc/$(src_dir_name)
-extra_configure_switches += --mandir=/usr/share/man
-extra_configure_switches += --disable-dependency-tracking
-extra_configure_switches += --sysconfdir=/etc
-extra_configure_switches += --localstatedir=/var
-ifeq ($(__ENABLE_STATIC__),yes)
-extra_configure_switches += --enable-static=yes
-else
-extra_configure_switches += --enable-static=no
-endif
-extra_configure_switches += --enable-shared=yes
-
-
-####### Dependencies
-
-$(src_done): $(SRC_ARCHIVE) $(PATCHES_DEP)
-	$(UNPACK_SRC_ARCHIVE)
-	$(APPLY_PATCHES)
-	@touch $@
-
-$(build_target): $(src_done)
-	@mkdir -p $(build_dir)
-	@cd $(build_dir) && $(BUILD_ENVIRONMENT) ../$(src_dir_name)/configure \
-	  --prefix=/usr               \
-	  --build=$(BUILD)            \
-	  --host=$(TARGET32)          \
-	  $(extra_configure_switches)
-	@cd $(build_dir) && $(BUILD_ENVIRONMENT) $(MAKE)
-	@touch $@
-
-$(install_target): $(build_target)
-	@mkdir -p $(LIBFFI32_PKG)
-	@cd $(build_dir) && $(BUILD_ENVIRONMENT) $(MAKE) -j1 install $(env_sysroot)
-	@rm -rf $(LIBFFI32_PKG)/usr/include
-	@rm -rf $(LIBFFI32_PKG)/usr/share
-	# ======= remove toolchain path from target libtool *.la files =======
-	@( cd $(LIBFFI32_PKG)/usr/lib$(MULTILIB_X86_32_SUFFIX) ; \
-	   sed -i "s,$(TARGET_DEST_DIR),,g" libffi.la  \
-	 )
-	# ======= Install the same to $(TARGET_DEST_DIR) =======
-	$(call install-into-devenv, $(LIBFFI32_PKG))
-	# ======= tune libtool *.la search path to the target destination for development =======
-	@( cd $(TARGET_DEST_DIR)/usr/lib$(MULTILIB_X86_32_SUFFIX) ; \
-	   sed -i "s,/usr,$(TARGET_DEST_DIR)/usr,g" libffi.la ; \
-	   sed -i "s,L/lib,L$(TARGET_DEST_DIR)/lib,g" libffi.la \
-	 )
-	# ======= tune pkg-config *.pc search path to the target destination for development =======
-	@( cd $(TARGET_DEST_DIR)/usr/lib$(MULTILIB_X86_32_SUFFIX)/pkgconfig ; \
-	   sed -i "s,/usr,$(TARGET_DEST_DIR)/usr,g" libffi.pc \
-	 )
-	# ======= Strip binaries =======
-	@( cd $(LIBFFI32_PKG) ; \
-	   find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs $(STRIP) --strip-unneeded 2> /dev/null ; \
-	   find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs $(STRIP) --strip-unneeded 2> /dev/null ; \
-	 )
-ifeq ($(__ENABLE_STATIC__),yes)
-	@( cd $(LIBFFI32_PKG) ; \
-	   find . | xargs file | grep "current ar archive" | cut -f 1 -d : | xargs $(STRIP) -g 2> /dev/null ; \
-	 )
-endif
-	@touch $@
-
-$(LIBFFI32_PKG_DESCRIPTION_FILE): $(LIBFFI32_PKG_DESCRIPTION_FILE_IN)
-	@cat $< | $(SED) -e "s/@VERSION@/$(version)/g" > $@
-
-$(pkg_certificate) : $(pkg_archive) ;
-$(pkg_signature)   : $(pkg_archive) ;
-$(pkg_description) : $(pkg_archive) ;
-
-$(pkg_archive): $(install_target) $(LIBFFI32_PKG_DESCRIPTION_FILE) $(LIBFFI32_PKG_INSTALL_SCRIPT)
-	@cp $(LIBFFI32_PKG_DESCRIPTION_FILE) $(LIBFFI32_PKG)/.DESCRIPTION
-	@cp $(LIBFFI32_PKG_INSTALL_SCRIPT) $(LIBFFI32_PKG)/.INSTALL
-	@$(BUILD_PKG_REQUIRES) $(LIBFFI32_PKG)/.REQUIRES
-	@echo "pkgname=$(LIBFFI32_PKG_NAME)"                            >  $(LIBFFI32_PKG)/.PKGINFO ; \
-	 echo "pkgver=$(LIBFFI32_PKG_VERSION)"                          >> $(LIBFFI32_PKG)/.PKGINFO ; \
-	 echo "arch=$(LIBFFI32_PKG_ARCH)"                               >> $(LIBFFI32_PKG)/.PKGINFO ; \
-	 echo "distroname=$(LIBFFI32_PKG_DISTRO_NAME)"                  >> $(LIBFFI32_PKG)/.PKGINFO ; \
-	 echo "distrover=$(LIBFFI32_PKG_DISTRO_VERSION)"                >> $(LIBFFI32_PKG)/.PKGINFO ; \
-	 echo "group=$(LIBFFI32_PKG_GROUP)"                             >> $(LIBFFI32_PKG)/.PKGINFO ; \
-	 echo "short_description=\"$(LIBFFI32_PKG_SHORT_DESCRIPTION)\"" >> $(LIBFFI32_PKG)/.PKGINFO ; \
-	 echo "url=$(LIBFFI32_PKG_URL)"                                 >> $(LIBFFI32_PKG)/.PKGINFO ; \
-	 echo "license=$(LIBFFI32_PKG_LICENSE)"                         >> $(LIBFFI32_PKG)/.PKGINFO
-	@$(PSEUDO) sh -c "cd $(LIBFFI32_PKG) && \
-	                  chown -R root:root . && \
-	                  $(MAKE_PACKAGE) -J --linkadd=yes $(GNUPG_OPTIONS) -m -d .. ."
Index: radix-1.8/libs/libffi/3.3-x86_32
===================================================================
--- radix-1.8/libs/libffi/3.3-x86_32	(revision 900)
+++ radix-1.8/libs/libffi/3.3-x86_32	(nonexistent)

Property changes on: radix-1.8/libs/libffi/3.3-x86_32
___________________________________________________________________
Deleted: svn:ignore
## -1,73 +0,0 ##
-
-# install dir
-dist
-
-# Target build dirs
-.a1x-newlib
-.a2x-newlib
-.at91sam7s-newlib
-
-.build-machine
-
-.a1x-glibc
-.a2x-glibc
-.h3-glibc
-.h5-glibc
-.i586-glibc
-.i686-glibc
-.imx6-glibc
-.jz47xx-glibc
-.makefile
-.am335x-glibc
-.omap543x-glibc
-.p5600-glibc
-.power8-glibc
-.power8le-glibc
-.power9-glibc
-.power9le-glibc
-.m1000-glibc
-.riscv64-glibc
-.rk328x-glibc
-.rk33xx-glibc
-.rk339x-glibc
-.s8xx-glibc
-.s9xx-glibc
-.x86_64-glibc
-
-# Hidden files (each file)
-.makefile
-.dist
-.rootfs
-
-# src & hw requires
-.src_requires
-.src_requires_depend
-.requires
-.requires_depend
-
-# Tarballs
-*.gz
-*.bz2
-*.lz
-*.xz
-*.tgz
-*.txz
-
-# Signatures
-*.asc
-*.sig
-*.sign
-*.sha1sum
-
-# Patches
-*.patch
-
-# Descriptions
-*.dsc
-*.txt
-
-# Default linux config files
-*.defconfig
-
-# backup copies
-*~
Index: radix-1.8/libs/libffi/3.3-ppc32/libffi-x32-pkg-description.in
===================================================================
--- radix-1.8/libs/libffi/3.3-ppc32/libffi-x32-pkg-description.in	(revision 900)
+++ radix-1.8/libs/libffi/3.3-ppc32/libffi-x32-pkg-description.in	(nonexistent)
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.  Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in.  You must
-# make exactly 11 lines for the formatting to be correct.  It's also
-# customary to leave one space after the ':'.
-
-          |-----handy-ruler------------------------------------------------------|
-libffi-x32: libffi-x32 @VERSION@ (A Portable Foreign Function Interface Lib)
-libffi-x32:
-libffi-x32: FFI stands for Foreign Function Interface.  A foreign function
-libffi-x32: interface is the popular name for the interface that allows code
-libffi-x32: written in one language to call code written in another language.
-libffi-x32: The libffi library really only provides the lowest, machine
-libffi-x32: dependent layer of a fully featured foreign function interface.
-libffi-x32:
-libffi-x32: Homepage: http://sourceware.org/libffi/
-libffi-x32:
-libffi-x32:
Index: radix-1.8/libs/libffi/3.3-ppc32/libffi-x32-pkg-install.sh
===================================================================
--- radix-1.8/libs/libffi/3.3-ppc32/libffi-x32-pkg-install.sh	(revision 900)
+++ radix-1.8/libs/libffi/3.3-ppc32/libffi-x32-pkg-install.sh	(nonexistent)
@@ -1,39 +0,0 @@
-#!/bin/sh
-
-# arg 1:  the new package version
-pre_install() {
-  /bin/true
-}
-
-# arg 1:  the new package version
-post_install() {
-  /bin/true
-}
-
-# arg 1:  the new package version
-# arg 2:  the old package version
-pre_update() {
-  /bin/true
-}
-
-# arg 1:  the new package version
-# arg 2:  the old package version
-post_update() {
-  post_install
-}
-
-# arg 1:  the old package version
-pre_remove() {
-  /bin/true
-}
-
-# arg 1:  the old package version
-post_remove() {
-  /bin/true
-}
-
-
-operation=$1
-shift
-
-$operation $*

Property changes on: radix-1.8/libs/libffi/3.3-ppc32/libffi-x32-pkg-install.sh
___________________________________________________________________
Deleted: svn:executable
## -1 +0,0 ##
-*
\ No newline at end of property
Index: radix-1.8/libs/libffi/3.3-ppc32/Makefile
===================================================================
--- radix-1.8/libs/libffi/3.3-ppc32/Makefile	(revision 900)
+++ radix-1.8/libs/libffi/3.3-ppc32/Makefile	(nonexistent)
@@ -1,167 +0,0 @@
-
-COMPONENT_TARGETS  = $(HARDWARE_S824L)
-COMPONENT_TARGETS += $(HARDWARE_VESNIN)
-COMPONENT_TARGETS += $(HARDWARE_TL2WK2)
-COMPONENT_TARGETS += $(HARDWARE_TL2SV2)
-
-NEED_ABS_PATH      = true
-COMPONENT_IS_3PP   = true
-
-CREATE_PPC32_PACKAGE = true
-
-
-include ../../../build-system/constants.mk
-
-
-SOURCE_REQUIRES    = sources/packages/l/libffi
-
-REQUIRES           = libs/libffi/3.3
-REQUIRES          += libs/glibc/2.34-ppc32
-
-# ======= __END_OF_REQUIRES__ =======
-
-
-version            = 3.3
-tar_gz_archive     = $(SRC_PACKAGE_PATH)/packages/l/libffi/libffi-$(version).tar.gz
-SRC_ARCHIVE        = $(tar_gz_archive)
-SRC_DIR            = $(TARGET_BUILD_DIR)/libffi-$(version)
-src_dir_name       = libffi-$(version)
-src_done           = $(TARGET_BUILD_DIR)/.source_done
-
-PATCHES = PATCHES
-
-build_dir          = $(TARGET_BUILD_DIR)/build
-build_target       = $(TARGET_BUILD_DIR)/.build_done
-install_target     = $(TARGET_BUILD_DIR)/.install_done
-
-
-####### Targets
-
-PKG_GROUP = libs
-#
-# *PKG_NAME & *PKG_VERSION shouldn't be a reference to value.
-#
-LIBFFI32_PKG_NAME                = libffi-x32
-LIBFFI32_PKG_VERSION             = 3.3
-LIBFFI32_PKG_ARCH                = $(TOOLCHAIN)
-LIBFFI32_PKG_DISTRO_NAME         = $(DISTRO_NAME)
-LIBFFI32_PKG_DISTRO_VERSION      = $(DISTRO_VERSION)
-LIBFFI32_PKG_GROUP               = $(PKG_GROUP)
-###                               |---handy-ruler-------------------------------|
-LIBFFI32_PKG_SHORT_DESCRIPTION   = Portable Foreign Function Interface Library
-LIBFFI32_PKG_URL                 = $(BUG_URL)
-LIBFFI32_PKG_LICENSE             = GPLv2
-LIBFFI32_PKG_DESCRIPTION_FILE    = $(TARGET_BUILD_DIR)/$(LIBFFI32_PKG_NAME)-pkg-description
-LIBFFI32_PKG_DESCRIPTION_FILE_IN = $(LIBFFI32_PKG_NAME)-pkg-description.in
-LIBFFI32_PKG_INSTALL_SCRIPT      = $(LIBFFI32_PKG_NAME)-pkg-install.sh
-
-LIBFFI32_PKG     = $(CURDIR)/$(TARGET_BUILD_DIR)/$(LIBFFI32_PKG_NAME)-package
-
-pkg_basename     = $(LIBFFI32_PKG_NAME)-$(LIBFFI32_PKG_VERSION)-$(LIBFFI32_PKG_ARCH)-$(LIBFFI32_PKG_DISTRO_NAME)-$(LIBFFI32_PKG_DISTRO_VERSION)
-
-pkg_archive      = $(TARGET_BUILD_DIR)/$(PKG_GROUP)/$(pkg_basename).$(pkg_arch_suffix)
-pkg_certificate  = $(call cert-name,$(pkg_archive))
-pkg_signature    = $(call sign-name,$(pkg_archive))
-pkg_description  = $(call desc-name,$(pkg_archive))
-products         = $(call pkg-files,$(pkg_archive))
-
-BUILD_TARGETS    = $(build_target)
-BUILD_TARGETS   += $(install_target)
-
-PRODUCT_TARGETS  = $(products)
-
-ROOTFS_TARGETS   = $(pkg_archive)
-
-
-include ../../../build-system/core.mk
-
-
-env_sysroot  = DESTDIR=$(LIBFFI32_PKG)
-
-
-extra_configure_switches  = --libdir=/usr/lib$(MULTILIB_PPC32_SUFFIX)
-extra_configure_switches += --docdir=/usr/share/doc/$(src_dir_name)
-extra_configure_switches += --mandir=/usr/share/man
-extra_configure_switches += --disable-dependency-tracking
-extra_configure_switches += --sysconfdir=/etc
-extra_configure_switches += --localstatedir=/var
-ifeq ($(__ENABLE_STATIC__),yes)
-extra_configure_switches += --enable-static=yes
-else
-extra_configure_switches += --enable-static=no
-endif
-extra_configure_switches += --enable-shared=yes
-
-
-####### Dependencies
-
-$(src_done): $(SRC_ARCHIVE) $(PATCHES_DEP)
-	$(UNPACK_SRC_ARCHIVE)
-	$(APPLY_PATCHES)
-	@touch $@
-
-$(build_target): $(src_done)
-	@mkdir -p $(build_dir)
-	@cd $(build_dir) && $(BUILD_ENVIRONMENT) ../$(src_dir_name)/configure \
-	  --prefix=/usr               \
-	  --build=$(BUILD)            \
-	  --host=$(TARGET32)          \
-	  $(extra_configure_switches)
-	@cd $(build_dir) && $(BUILD_ENVIRONMENT) $(MAKE)
-	@touch $@
-
-$(install_target): $(build_target)
-	@mkdir -p $(LIBFFI32_PKG)
-	@cd $(build_dir) && $(BUILD_ENVIRONMENT) $(MAKE) -j1 install $(env_sysroot)
-	@rm -rf $(LIBFFI32_PKG)/usr/include
-	@rm -rf $(LIBFFI32_PKG)/usr/share
-	# ======= remove toolchain path from target libtool *.la files =======
-	@( cd $(LIBFFI32_PKG)/usr/lib$(MULTILIB_PPC32_SUFFIX) ; \
-	   sed -i "s,$(TARGET_DEST_DIR),,g" libffi.la  \
-	 )
-	# ======= Install the same to $(TARGET_DEST_DIR) =======
-	$(call install-into-devenv, $(LIBFFI32_PKG))
-	# ======= tune libtool *.la search path to the target destination for development =======
-	@( cd $(TARGET_DEST_DIR)/usr/lib$(MULTILIB_PPC32_SUFFIX) ; \
-	   sed -i "s,/usr,$(TARGET_DEST_DIR)/usr,g" libffi.la ; \
-	   sed -i "s,L/lib,L$(TARGET_DEST_DIR)/lib,g" libffi.la \
-	 )
-	# ======= tune pkg-config *.pc search path to the target destination for development =======
-	@( cd $(TARGET_DEST_DIR)/usr/lib$(MULTILIB_PPC32_SUFFIX)/pkgconfig ; \
-	   sed -i "s,/usr,$(TARGET_DEST_DIR)/usr,g" libffi.pc \
-	 )
-	# ======= Strip binaries =======
-	@( cd $(LIBFFI32_PKG) ; \
-	   find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs $(STRIP) --strip-unneeded 2> /dev/null ; \
-	   find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs $(STRIP) --strip-unneeded 2> /dev/null ; \
-	 )
-ifeq ($(__ENABLE_STATIC__),yes)
-	@( cd $(LIBFFI32_PKG) ; \
-	   find . | xargs file | grep "current ar archive" | cut -f 1 -d : | xargs $(STRIP) -g 2> /dev/null ; \
-	 )
-endif
-	@touch $@
-
-$(LIBFFI32_PKG_DESCRIPTION_FILE): $(LIBFFI32_PKG_DESCRIPTION_FILE_IN)
-	@cat $< | $(SED) -e "s/@VERSION@/$(version)/g" > $@
-
-$(pkg_certificate) : $(pkg_archive) ;
-$(pkg_signature)   : $(pkg_archive) ;
-$(pkg_description) : $(pkg_archive) ;
-
-$(pkg_archive): $(install_target) $(LIBFFI32_PKG_DESCRIPTION_FILE) $(LIBFFI32_PKG_INSTALL_SCRIPT)
-	@cp $(LIBFFI32_PKG_DESCRIPTION_FILE) $(LIBFFI32_PKG)/.DESCRIPTION
-	@cp $(LIBFFI32_PKG_INSTALL_SCRIPT) $(LIBFFI32_PKG)/.INSTALL
-	@$(BUILD_PKG_REQUIRES) $(LIBFFI32_PKG)/.REQUIRES
-	@echo "pkgname=$(LIBFFI32_PKG_NAME)"                            >  $(LIBFFI32_PKG)/.PKGINFO ; \
-	 echo "pkgver=$(LIBFFI32_PKG_VERSION)"                          >> $(LIBFFI32_PKG)/.PKGINFO ; \
-	 echo "arch=$(LIBFFI32_PKG_ARCH)"                               >> $(LIBFFI32_PKG)/.PKGINFO ; \
-	 echo "distroname=$(LIBFFI32_PKG_DISTRO_NAME)"                  >> $(LIBFFI32_PKG)/.PKGINFO ; \
-	 echo "distrover=$(LIBFFI32_PKG_DISTRO_VERSION)"                >> $(LIBFFI32_PKG)/.PKGINFO ; \
-	 echo "group=$(LIBFFI32_PKG_GROUP)"                             >> $(LIBFFI32_PKG)/.PKGINFO ; \
-	 echo "short_description=\"$(LIBFFI32_PKG_SHORT_DESCRIPTION)\"" >> $(LIBFFI32_PKG)/.PKGINFO ; \
-	 echo "url=$(LIBFFI32_PKG_URL)"                                 >> $(LIBFFI32_PKG)/.PKGINFO ; \
-	 echo "license=$(LIBFFI32_PKG_LICENSE)"                         >> $(LIBFFI32_PKG)/.PKGINFO
-	@$(PSEUDO) sh -c "cd $(LIBFFI32_PKG) && \
-	                  chown -R root:root . && \
-	                  $(MAKE_PACKAGE) -J --linkadd=yes $(GNUPG_OPTIONS) -m -d .. ."
Index: radix-1.8/libs/libffi/3.3-ppc32
===================================================================
--- radix-1.8/libs/libffi/3.3-ppc32	(revision 900)
+++ radix-1.8/libs/libffi/3.3-ppc32	(nonexistent)

Property changes on: radix-1.8/libs/libffi/3.3-ppc32
___________________________________________________________________
Deleted: svn:ignore
## -1,73 +0,0 ##
-
-# install dir
-dist
-
-# Target build dirs
-.a1x-newlib
-.a2x-newlib
-.at91sam7s-newlib
-
-.build-machine
-
-.a1x-glibc
-.a2x-glibc
-.h3-glibc
-.h5-glibc
-.i586-glibc
-.i686-glibc
-.imx6-glibc
-.jz47xx-glibc
-.makefile
-.am335x-glibc
-.omap543x-glibc
-.p5600-glibc
-.power8-glibc
-.power8le-glibc
-.power9-glibc
-.power9le-glibc
-.m1000-glibc
-.riscv64-glibc
-.rk328x-glibc
-.rk33xx-glibc
-.rk339x-glibc
-.s8xx-glibc
-.s9xx-glibc
-.x86_64-glibc
-
-# Hidden files (each file)
-.makefile
-.dist
-.rootfs
-
-# src & hw requires
-.src_requires
-.src_requires_depend
-.requires
-.requires_depend
-
-# Tarballs
-*.gz
-*.bz2
-*.lz
-*.xz
-*.tgz
-*.txz
-
-# Signatures
-*.asc
-*.sig
-*.sign
-*.sha1sum
-
-# Patches
-*.patch
-
-# Descriptions
-*.dsc
-*.txt
-
-# Default linux config files
-*.defconfig
-
-# backup copies
-*~
Index: radix-1.8/libs/libffi/3.4.2/Makefile
===================================================================
--- radix-1.8/libs/libffi/3.4.2/Makefile	(nonexistent)
+++ radix-1.8/libs/libffi/3.4.2/Makefile	(revision 901)
@@ -0,0 +1,236 @@
+
+COMPONENT_TARGETS  = $(HARDWARE_INTEL_PC32)
+COMPONENT_TARGETS += $(HARDWARE_INTEL_PC64)
+COMPONENT_TARGETS += $(HARDWARE_EBOX_3350DX2)
+COMPONENT_TARGETS += $(HARDWARE_CB1X)
+COMPONENT_TARGETS += $(HARDWARE_CB2X)
+COMPONENT_TARGETS += $(HARDWARE_CB3X)
+COMPONENT_TARGETS += $(HARDWARE_ORANGE_PP2E)
+COMPONENT_TARGETS += $(HARDWARE_NANOPI_NEO)
+COMPONENT_TARGETS += $(HARDWARE_ORANGE_PP)
+COMPONENT_TARGETS += $(HARDWARE_ORANGE_PL2)
+COMPONENT_TARGETS += $(HARDWARE_WECHIP_TX6)
+COMPONENT_TARGETS += $(HARDWARE_FFRK3288)
+COMPONENT_TARGETS += $(HARDWARE_POIN2)
+COMPONENT_TARGETS += $(HARDWARE_RK3328_CC)
+COMPONENT_TARGETS += $(HARDWARE_KHADAS_EDGE)
+COMPONENT_TARGETS += $(HARDWARE_LEEZ_P710)
+COMPONENT_TARGETS += $(HARDWARE_M201)
+COMPONENT_TARGETS += $(HARDWARE_MXV)
+COMPONENT_TARGETS += $(HARDWARE_P201)
+COMPONENT_TARGETS += $(HARDWARE_NEXBOX_A95X)
+COMPONENT_TARGETS += $(HARDWARE_ODROID_C2)
+COMPONENT_TARGETS += $(HARDWARE_P212)
+COMPONENT_TARGETS += $(HARDWARE_KHADAS_VIM)
+COMPONENT_TARGETS += $(HARDWARE_Q201)
+COMPONENT_TARGETS += $(HARDWARE_ENYBOX_X2)
+COMPONENT_TARGETS += $(HARDWARE_KHADAS_VIM2)
+COMPONENT_TARGETS += $(HARDWARE_NIT6Q)
+COMPONENT_TARGETS += $(HARDWARE_OKMX6DL_C)
+COMPONENT_TARGETS += $(HARDWARE_OKMX6Q_C)
+COMPONENT_TARGETS += $(HARDWARE_BONE_BLACK)
+COMPONENT_TARGETS += $(HARDWARE_OMAP5UEVM)
+COMPONENT_TARGETS += $(HARDWARE_DRA7XXEVM)
+COMPONENT_TARGETS += $(HARDWARE_CI20)
+COMPONENT_TARGETS += $(HARDWARE_BAIKAL_T1)
+COMPONENT_TARGETS += $(HARDWARE_BAIKAL_M1)
+COMPONENT_TARGETS += $(HARDWARE_S824L)
+COMPONENT_TARGETS += $(HARDWARE_VESNIN)
+COMPONENT_TARGETS += $(HARDWARE_S824L_LSB)
+COMPONENT_TARGETS += $(HARDWARE_VESNIN_LSB)
+COMPONENT_TARGETS += $(HARDWARE_TL2WK2)
+COMPONENT_TARGETS += $(HARDWARE_TL2SV2)
+COMPONENT_TARGETS += $(HARDWARE_TL2WK2_LSB)
+COMPONENT_TARGETS += $(HARDWARE_TL2SV2_LSB)
+COMPONENT_TARGETS += $(HARDWARE_SIFIVE_U740)
+
+
+NEED_ABS_PATH      = true
+COMPONENT_IS_3PP   = true
+
+
+include ../../../build-system/constants.mk
+
+
+SOURCE_REQUIRES    = sources/packages/l/libffi
+
+ifeq ($(__USE_BUILT_GCC_LIBS__),yes)
+REQUIRES           = dev/gcc/11.2.0
+else
+REQUIRES           = libs/glibc/2.34
+endif
+
+# ======= __END_OF_REQUIRES__ =======
+
+
+version            = 3.4.2
+tar_gz_archive     = $(SRC_PACKAGE_PATH)/packages/l/libffi/libffi-$(version).tar.gz
+SRC_ARCHIVE        = $(tar_gz_archive)
+SRC_DIR            = $(TARGET_BUILD_DIR)/libffi-$(version)
+src_dir_name       = libffi-$(version)
+src_done           = $(TARGET_BUILD_DIR)/.source_done
+
+PATCHES = PATCHES
+
+build_dir          = $(TARGET_BUILD_DIR)/build
+build_target       = $(TARGET_BUILD_DIR)/.build_done
+install_target     = $(TARGET_BUILD_DIR)/.install_done
+
+
+####### Targets
+
+PKG_GROUP = libs
+
+#
+# *PKG_NAME & *PKG_VERSION shouldn't be a reference to value.
+#
+LIBFFI_PKG_NAME                = libffi
+LIBFFI_PKG_VERSION             = 3.4.2
+LIBFFI_PKG_ARCH                = $(TOOLCHAIN)
+LIBFFI_PKG_DISTRO_NAME         = $(DISTRO_NAME)
+LIBFFI_PKG_DISTRO_VERSION      = $(DISTRO_VERSION)
+LIBFFI_PKG_GROUP               = $(PKG_GROUP)
+###                             |---handy-ruler-------------------------------|
+LIBFFI_PKG_SHORT_DESCRIPTION   = Portable Foreign Function Interface Library
+LIBFFI_PKG_URL                 = $(BUG_URL)
+LIBFFI_PKG_LICENSE             = GPLv2
+LIBFFI_PKG_DESCRIPTION_FILE    = $(TARGET_BUILD_DIR)/$(LIBFFI_PKG_NAME)-pkg-description
+LIBFFI_PKG_DESCRIPTION_FILE_IN = $(LIBFFI_PKG_NAME)-pkg-description.in
+LIBFFI_PKG_INSTALL_SCRIPT      = $(LIBFFI_PKG_NAME)-pkg-install.sh
+
+LIBFFI_PKG       = $(CURDIR)/$(TARGET_BUILD_DIR)/$(LIBFFI_PKG_NAME)-package
+
+pkg_basename     = $(LIBFFI_PKG_NAME)-$(LIBFFI_PKG_VERSION)-$(LIBFFI_PKG_ARCH)-$(LIBFFI_PKG_DISTRO_NAME)-$(LIBFFI_PKG_DISTRO_VERSION)
+
+pkg_archive      = $(TARGET_BUILD_DIR)/$(PKG_GROUP)/$(pkg_basename).$(pkg_arch_suffix)
+pkg_certificate  = $(call cert-name,$(pkg_archive))
+pkg_signature    = $(call sign-name,$(pkg_archive))
+pkg_description  = $(call desc-name,$(pkg_archive))
+products         = $(call pkg-files,$(pkg_archive))
+
+BUILD_TARGETS    = $(build_target)
+BUILD_TARGETS   += $(install_target)
+
+PRODUCT_TARGETS  = $(products)
+
+ROOTFS_TARGETS   = $(pkg_archive)
+
+
+include ../../../build-system/core.mk
+
+
+env_sysroot = DESTDIR=$(LIBFFI_PKG)
+
+
+extra_configure_switches  = --libdir=/usr/lib$(LIBSUFFIX)
+extra_configure_switches += --docdir=/usr/share/doc/$(src_dir_name)
+extra_configure_switches += --mandir=/usr/share/man
+extra_configure_switches += --disable-dependency-tracking
+extra_configure_switches += --sysconfdir=/etc
+extra_configure_switches += --localstatedir=/var
+ifeq ($(__ENABLE_STATIC__),yes)
+extra_configure_switches += --enable-static=yes
+else
+extra_configure_switches += --enable-static=no
+endif
+extra_configure_switches += --enable-shared=yes
+
+
+####### Dependencies
+
+$(src_done): $(SRC_ARCHIVE) $(PATCHES_DEP)
+	$(UNPACK_SRC_ARCHIVE)
+	$(APPLY_PATCHES)
+	@( cd $(SRC_DIR) ; ./autogen.sh )
+	@touch $@
+
+$(build_target): $(src_done)
+	@mkdir -p $(build_dir)
+	@cd $(build_dir) && \
+	  $(BUILD_ENVIRONMENT) ../$(src_dir_name)/configure \
+	  --prefix=/usr               \
+	  --build=$(BUILD)            \
+	  --host=$(TARGET)            \
+	  $(extra_configure_switches)
+	@cd $(build_dir) && $(BUILD_ENVIRONMENT) $(MAKE)
+	@touch $@
+
+$(install_target): $(build_target)
+	@mkdir -p $(LIBFFI_PKG)
+	@cd $(build_dir) && $(BUILD_ENVIRONMENT) $(MAKE) -j1 install $(env_sysroot)
+	# ======= Install Documentation =======
+	@rm -f $(LIBFFI_PKG)/usr/share/info/dir
+	@gzip -9 $(LIBFFI_PKG)/usr/share/info/*
+	@if [ -d $(LIBFFI_PKG)/usr/share/man ]; then \
+	  ( cd $(LIBFFI_PKG)/usr/share/man ; \
+	    for manpagedir in `find . -type d -name "man*"` ; do \
+	      ( cd $$manpagedir ; \
+	        for eachpage in `find . -type l -maxdepth 1` ; do \
+	          ln -s `readlink $$eachpage`.gz $$eachpage.gz ; \
+	          rm $$eachpage ; \
+	        done ; \
+	        gzip -9 *.?  ; \
+	      ) \
+	    done \
+	  ) \
+	 fi
+	@mkdir -p $(LIBFFI_PKG)/usr/doc/$(src_dir_name)
+	@cp -a $(SRC_DIR)/LICENSE* $(SRC_DIR)/README* $(SRC_DIR)/doc/libffi.pdf \
+	       $(LIBFFI_PKG)/usr/doc/$(src_dir_name)
+	@( cd $(SRC_DIR) ; \
+	   if [ -r ChangeLog ]; then \
+	     DOCSDIR=`echo $(LIBFFI_PKG)/usr/doc/$(src_dir_name)` ; \
+	     cat ChangeLog | head -n 1000 > $$DOCSDIR/ChangeLog ; \
+	     touch -r ChangeLog $$DOCSDIR/ChangeLog ; \
+	   fi \
+	 )
+	# ======= remove toolchain path from target libtool *.la files =======
+	@( cd $(LIBFFI_PKG)/usr/lib$(LIBSUFFIX) ; \
+	   sed -i "s,$(TARGET_DEST_DIR),,g" libffi.la  \
+	 )
+	# ======= Install the same to $(TARGET_DEST_DIR) =======
+	$(call install-into-devenv, $(LIBFFI_PKG))
+	# ======= tune libtool *.la search path to the target destination for development =======
+	@( cd $(TARGET_DEST_DIR)/usr/lib$(LIBSUFFIX) ; \
+	   sed -i "s,/usr,$(TARGET_DEST_DIR)/usr,g" libffi.la ; \
+	   sed -i "s,L/lib,L$(TARGET_DEST_DIR)/lib,g" libffi.la \
+	 )
+	# ======= tune pkg-config *.pc search path to the target destination for development =======
+	@( cd $(TARGET_DEST_DIR)/usr/lib$(LIBSUFFIX)/pkgconfig ; \
+	   sed -i "s,/usr,$(TARGET_DEST_DIR)/usr,g" libffi.pc \
+	 )
+	# ======= Strip binaries =======
+	@( cd $(LIBFFI_PKG) ; \
+	   find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs $(STRIP) --strip-unneeded 2> /dev/null ; \
+	   find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs $(STRIP) --strip-unneeded 2> /dev/null ; \
+	 )
+ifeq ($(__ENABLE_STATIC__),yes)
+	@( cd $(LIBFFI_PKG) ; \
+	   find . | xargs file | grep "current ar archive" | cut -f 1 -d : | xargs $(STRIP) -g 2> /dev/null ; \
+	 )
+endif
+	@touch $@
+
+$(LIBFFI_PKG_DESCRIPTION_FILE): $(LIBFFI_PKG_DESCRIPTION_FILE_IN)
+	@cat $< | $(SED) -e "s/@VERSION@/$(version)/g" > $@
+
+$(pkg_certificate) : $(pkg_archive) ;
+$(pkg_signature)   : $(pkg_archive) ;
+$(pkg_description) : $(pkg_archive) ;
+
+$(pkg_archive): $(install_target) $(LIBFFI_PKG_DESCRIPTION_FILE) $(LIBFFI_PKG_INSTALL_SCRIPT)
+	@cp $(LIBFFI_PKG_DESCRIPTION_FILE) $(LIBFFI_PKG)/.DESCRIPTION
+	@cp $(LIBFFI_PKG_INSTALL_SCRIPT) $(LIBFFI_PKG)/.INSTALL
+	@$(BUILD_PKG_REQUIRES) $(LIBFFI_PKG)/.REQUIRES
+	@echo "pkgname=$(LIBFFI_PKG_NAME)"                            >  $(LIBFFI_PKG)/.PKGINFO ; \
+	 echo "pkgver=$(LIBFFI_PKG_VERSION)"                          >> $(LIBFFI_PKG)/.PKGINFO ; \
+	 echo "arch=$(LIBFFI_PKG_ARCH)"                               >> $(LIBFFI_PKG)/.PKGINFO ; \
+	 echo "distroname=$(LIBFFI_PKG_DISTRO_NAME)"                  >> $(LIBFFI_PKG)/.PKGINFO ; \
+	 echo "distrover=$(LIBFFI_PKG_DISTRO_VERSION)"                >> $(LIBFFI_PKG)/.PKGINFO ; \
+	 echo "group=$(LIBFFI_PKG_GROUP)"                             >> $(LIBFFI_PKG)/.PKGINFO ; \
+	 echo "short_description=\"$(LIBFFI_PKG_SHORT_DESCRIPTION)\"" >> $(LIBFFI_PKG)/.PKGINFO ; \
+	 echo "url=$(LIBFFI_PKG_URL)"                                 >> $(LIBFFI_PKG)/.PKGINFO ; \
+	 echo "license=$(LIBFFI_PKG_LICENSE)"                         >> $(LIBFFI_PKG)/.PKGINFO
+	@$(PSEUDO) sh -c "cd $(LIBFFI_PKG) && \
+	                  chown -R root:root . && \
+	                  $(MAKE_PACKAGE) -J --linkadd=yes $(GNUPG_OPTIONS) -m -d .. ."
Index: radix-1.8/libs/libffi/3.4.2/PATCHES
===================================================================
Index: radix-1.8/libs/libffi/3.4.2/libffi-pkg-description.in
===================================================================
--- radix-1.8/libs/libffi/3.4.2/libffi-pkg-description.in	(nonexistent)
+++ radix-1.8/libs/libffi/3.4.2/libffi-pkg-description.in	(revision 901)
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.  Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in.  You must
+# make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':'.
+
+      |-----handy-ruler------------------------------------------------------|
+libffi: libffi @VERSION@ (A Portable Foreign Function Interface Library)
+libffi:
+libffi: FFI stands for Foreign Function Interface.  A foreign function
+libffi: interface is the popular name for the interface that allows code
+libffi: written in one language to call code written in another language.
+libffi: The libffi library really only provides the lowest, machine
+libffi: dependent layer of a fully featured foreign function interface.
+libffi:
+libffi: Homepage: http://sourceware.org/libffi/
+libffi:
+libffi:
Index: radix-1.8/libs/libffi/3.4.2/libffi-pkg-install.sh
===================================================================
--- radix-1.8/libs/libffi/3.4.2/libffi-pkg-install.sh	(nonexistent)
+++ radix-1.8/libs/libffi/3.4.2/libffi-pkg-install.sh	(revision 901)
@@ -0,0 +1,69 @@
+#!/bin/sh
+
+# Preserve new files
+install_file() {
+  NEW="$1"
+  OLD="`dirname $NEW`/`basename $NEW .new`"
+  # If there's no file by that name, mv it over:
+  if [ ! -r $OLD ]; then
+    mv $NEW $OLD
+  elif [ "`cat $OLD | md5sum`" = "`cat $NEW | md5sum`" ]; then # toss the redundant copy
+    rm $NEW
+  fi
+  # Otherwise, we leave the .new copy for the admin to consider...
+}
+
+
+# arg 1:  the new package version
+pre_install() {
+  /bin/true
+}
+
+# arg 1:  the new package version
+post_install() {
+  #
+  # NOTE:
+  #   'install-info' can work using relative paths and we can make use build machine
+  #   utility during installation to the some partition and use target 'install-info'
+  #   during installation directly on the running target machine.
+  #
+  if [ -x /usr/bin/install-info ] ; then
+    install-info --info-dir=usr/share/info usr/share/info/libffi.info.gz  2>/dev/null
+  elif ! grep "(libffi)" usr/share/info/dir 1> /dev/null 2> /dev/null ; then
+  cat << EOF >> usr/share/info/dir
+
+Development
+* libffi: (libffi).             Portable foreign function interface library.
+EOF
+  fi
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+pre_update() {
+  /bin/true
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+post_update() {
+  post_install
+}
+
+# arg 1:  the old package version
+pre_remove() {
+  if [ -x /usr/bin/install-info ] ; then
+    install-info --delete --info-file=usr/share/info/libffi.info.gz --dir-file=usr/share/info/dir 2> /dev/null || /bin/true
+  fi
+}
+
+# arg 1:  the old package version
+post_remove() {
+  /bin/true
+}
+
+
+operation=$1
+shift
+
+$operation $*

Property changes on: radix-1.8/libs/libffi/3.4.2/libffi-pkg-install.sh
___________________________________________________________________
Added: svn:executable
## -0,0 +1 ##
+*
\ No newline at end of property
Index: radix-1.8/libs/libffi/3.4.2
===================================================================
--- radix-1.8/libs/libffi/3.4.2	(nonexistent)
+++ radix-1.8/libs/libffi/3.4.2	(revision 901)

Property changes on: radix-1.8/libs/libffi/3.4.2
___________________________________________________________________
Added: svn:ignore
## -0,0 +1,73 ##
+
+# install dir
+dist
+
+# Target build dirs
+.a1x-newlib
+.a2x-newlib
+.at91sam7s-newlib
+
+.build-machine
+
+.a1x-glibc
+.a2x-glibc
+.h3-glibc
+.h5-glibc
+.i586-glibc
+.i686-glibc
+.imx6-glibc
+.jz47xx-glibc
+.makefile
+.am335x-glibc
+.omap543x-glibc
+.p5600-glibc
+.power8-glibc
+.power8le-glibc
+.power9-glibc
+.power9le-glibc
+.m1000-glibc
+.riscv64-glibc
+.rk328x-glibc
+.rk33xx-glibc
+.rk339x-glibc
+.s8xx-glibc
+.s9xx-glibc
+.x86_64-glibc
+
+# Hidden files (each file)
+.makefile
+.dist
+.rootfs
+
+# src & hw requires
+.src_requires
+.src_requires_depend
+.requires
+.requires_depend
+
+# Tarballs
+*.gz
+*.bz2
+*.lz
+*.xz
+*.tgz
+*.txz
+
+# Signatures
+*.asc
+*.sig
+*.sign
+*.sha1sum
+
+# Patches
+*.patch
+
+# Descriptions
+*.dsc
+*.txt
+
+# Default linux config files
+*.defconfig
+
+# backup copies
+*~
Index: radix-1.8/libs/libffi/3.4.2-ppc32/Makefile
===================================================================
--- radix-1.8/libs/libffi/3.4.2-ppc32/Makefile	(nonexistent)
+++ radix-1.8/libs/libffi/3.4.2-ppc32/Makefile	(revision 901)
@@ -0,0 +1,168 @@
+
+COMPONENT_TARGETS  = $(HARDWARE_S824L)
+COMPONENT_TARGETS += $(HARDWARE_VESNIN)
+COMPONENT_TARGETS += $(HARDWARE_TL2WK2)
+COMPONENT_TARGETS += $(HARDWARE_TL2SV2)
+
+NEED_ABS_PATH      = true
+COMPONENT_IS_3PP   = true
+
+CREATE_PPC32_PACKAGE = true
+
+
+include ../../../build-system/constants.mk
+
+
+SOURCE_REQUIRES    = sources/packages/l/libffi
+
+REQUIRES           = libs/libffi/3.4.2
+REQUIRES          += libs/glibc/2.34-ppc32
+
+# ======= __END_OF_REQUIRES__ =======
+
+
+version            = 3.4.2
+tar_gz_archive     = $(SRC_PACKAGE_PATH)/packages/l/libffi/libffi-$(version).tar.gz
+SRC_ARCHIVE        = $(tar_gz_archive)
+SRC_DIR            = $(TARGET_BUILD_DIR)/libffi-$(version)
+src_dir_name       = libffi-$(version)
+src_done           = $(TARGET_BUILD_DIR)/.source_done
+
+PATCHES = PATCHES
+
+build_dir          = $(TARGET_BUILD_DIR)/build
+build_target       = $(TARGET_BUILD_DIR)/.build_done
+install_target     = $(TARGET_BUILD_DIR)/.install_done
+
+
+####### Targets
+
+PKG_GROUP = libs
+#
+# *PKG_NAME & *PKG_VERSION shouldn't be a reference to value.
+#
+LIBFFI32_PKG_NAME                = libffi-x32
+LIBFFI32_PKG_VERSION             = 3.4.2
+LIBFFI32_PKG_ARCH                = $(TOOLCHAIN)
+LIBFFI32_PKG_DISTRO_NAME         = $(DISTRO_NAME)
+LIBFFI32_PKG_DISTRO_VERSION      = $(DISTRO_VERSION)
+LIBFFI32_PKG_GROUP               = $(PKG_GROUP)
+###                               |---handy-ruler-------------------------------|
+LIBFFI32_PKG_SHORT_DESCRIPTION   = Portable Foreign Function Interface Library
+LIBFFI32_PKG_URL                 = $(BUG_URL)
+LIBFFI32_PKG_LICENSE             = GPLv2
+LIBFFI32_PKG_DESCRIPTION_FILE    = $(TARGET_BUILD_DIR)/$(LIBFFI32_PKG_NAME)-pkg-description
+LIBFFI32_PKG_DESCRIPTION_FILE_IN = $(LIBFFI32_PKG_NAME)-pkg-description.in
+LIBFFI32_PKG_INSTALL_SCRIPT      = $(LIBFFI32_PKG_NAME)-pkg-install.sh
+
+LIBFFI32_PKG     = $(CURDIR)/$(TARGET_BUILD_DIR)/$(LIBFFI32_PKG_NAME)-package
+
+pkg_basename     = $(LIBFFI32_PKG_NAME)-$(LIBFFI32_PKG_VERSION)-$(LIBFFI32_PKG_ARCH)-$(LIBFFI32_PKG_DISTRO_NAME)-$(LIBFFI32_PKG_DISTRO_VERSION)
+
+pkg_archive      = $(TARGET_BUILD_DIR)/$(PKG_GROUP)/$(pkg_basename).$(pkg_arch_suffix)
+pkg_certificate  = $(call cert-name,$(pkg_archive))
+pkg_signature    = $(call sign-name,$(pkg_archive))
+pkg_description  = $(call desc-name,$(pkg_archive))
+products         = $(call pkg-files,$(pkg_archive))
+
+BUILD_TARGETS    = $(build_target)
+BUILD_TARGETS   += $(install_target)
+
+PRODUCT_TARGETS  = $(products)
+
+ROOTFS_TARGETS   = $(pkg_archive)
+
+
+include ../../../build-system/core.mk
+
+
+env_sysroot  = DESTDIR=$(LIBFFI32_PKG)
+
+
+extra_configure_switches  = --libdir=/usr/lib$(MULTILIB_PPC32_SUFFIX)
+extra_configure_switches += --docdir=/usr/share/doc/$(src_dir_name)
+extra_configure_switches += --mandir=/usr/share/man
+extra_configure_switches += --disable-dependency-tracking
+extra_configure_switches += --sysconfdir=/etc
+extra_configure_switches += --localstatedir=/var
+ifeq ($(__ENABLE_STATIC__),yes)
+extra_configure_switches += --enable-static=yes
+else
+extra_configure_switches += --enable-static=no
+endif
+extra_configure_switches += --enable-shared=yes
+
+
+####### Dependencies
+
+$(src_done): $(SRC_ARCHIVE) $(PATCHES_DEP)
+	$(UNPACK_SRC_ARCHIVE)
+	$(APPLY_PATCHES)
+	@( cd $(SRC_DIR) ; ./autogen.sh )
+	@touch $@
+
+$(build_target): $(src_done)
+	@mkdir -p $(build_dir)
+	@cd $(build_dir) && $(BUILD_ENVIRONMENT) ../$(src_dir_name)/configure \
+	  --prefix=/usr               \
+	  --build=$(BUILD)            \
+	  --host=$(TARGET32)          \
+	  $(extra_configure_switches)
+	@cd $(build_dir) && $(BUILD_ENVIRONMENT) $(MAKE)
+	@touch $@
+
+$(install_target): $(build_target)
+	@mkdir -p $(LIBFFI32_PKG)
+	@cd $(build_dir) && $(BUILD_ENVIRONMENT) $(MAKE) -j1 install $(env_sysroot)
+	@rm -rf $(LIBFFI32_PKG)/usr/include
+	@rm -rf $(LIBFFI32_PKG)/usr/share
+	# ======= remove toolchain path from target libtool *.la files =======
+	@( cd $(LIBFFI32_PKG)/usr/lib$(MULTILIB_PPC32_SUFFIX) ; \
+	   sed -i "s,$(TARGET_DEST_DIR),,g" libffi.la  \
+	 )
+	# ======= Install the same to $(TARGET_DEST_DIR) =======
+	$(call install-into-devenv, $(LIBFFI32_PKG))
+	# ======= tune libtool *.la search path to the target destination for development =======
+	@( cd $(TARGET_DEST_DIR)/usr/lib$(MULTILIB_PPC32_SUFFIX) ; \
+	   sed -i "s,/usr,$(TARGET_DEST_DIR)/usr,g" libffi.la ; \
+	   sed -i "s,L/lib,L$(TARGET_DEST_DIR)/lib,g" libffi.la \
+	 )
+	# ======= tune pkg-config *.pc search path to the target destination for development =======
+	@( cd $(TARGET_DEST_DIR)/usr/lib$(MULTILIB_PPC32_SUFFIX)/pkgconfig ; \
+	   sed -i "s,/usr,$(TARGET_DEST_DIR)/usr,g" libffi.pc \
+	 )
+	# ======= Strip binaries =======
+	@( cd $(LIBFFI32_PKG) ; \
+	   find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs $(STRIP) --strip-unneeded 2> /dev/null ; \
+	   find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs $(STRIP) --strip-unneeded 2> /dev/null ; \
+	 )
+ifeq ($(__ENABLE_STATIC__),yes)
+	@( cd $(LIBFFI32_PKG) ; \
+	   find . | xargs file | grep "current ar archive" | cut -f 1 -d : | xargs $(STRIP) -g 2> /dev/null ; \
+	 )
+endif
+	@touch $@
+
+$(LIBFFI32_PKG_DESCRIPTION_FILE): $(LIBFFI32_PKG_DESCRIPTION_FILE_IN)
+	@cat $< | $(SED) -e "s/@VERSION@/$(version)/g" > $@
+
+$(pkg_certificate) : $(pkg_archive) ;
+$(pkg_signature)   : $(pkg_archive) ;
+$(pkg_description) : $(pkg_archive) ;
+
+$(pkg_archive): $(install_target) $(LIBFFI32_PKG_DESCRIPTION_FILE) $(LIBFFI32_PKG_INSTALL_SCRIPT)
+	@cp $(LIBFFI32_PKG_DESCRIPTION_FILE) $(LIBFFI32_PKG)/.DESCRIPTION
+	@cp $(LIBFFI32_PKG_INSTALL_SCRIPT) $(LIBFFI32_PKG)/.INSTALL
+	@$(BUILD_PKG_REQUIRES) $(LIBFFI32_PKG)/.REQUIRES
+	@echo "pkgname=$(LIBFFI32_PKG_NAME)"                            >  $(LIBFFI32_PKG)/.PKGINFO ; \
+	 echo "pkgver=$(LIBFFI32_PKG_VERSION)"                          >> $(LIBFFI32_PKG)/.PKGINFO ; \
+	 echo "arch=$(LIBFFI32_PKG_ARCH)"                               >> $(LIBFFI32_PKG)/.PKGINFO ; \
+	 echo "distroname=$(LIBFFI32_PKG_DISTRO_NAME)"                  >> $(LIBFFI32_PKG)/.PKGINFO ; \
+	 echo "distrover=$(LIBFFI32_PKG_DISTRO_VERSION)"                >> $(LIBFFI32_PKG)/.PKGINFO ; \
+	 echo "group=$(LIBFFI32_PKG_GROUP)"                             >> $(LIBFFI32_PKG)/.PKGINFO ; \
+	 echo "short_description=\"$(LIBFFI32_PKG_SHORT_DESCRIPTION)\"" >> $(LIBFFI32_PKG)/.PKGINFO ; \
+	 echo "url=$(LIBFFI32_PKG_URL)"                                 >> $(LIBFFI32_PKG)/.PKGINFO ; \
+	 echo "license=$(LIBFFI32_PKG_LICENSE)"                         >> $(LIBFFI32_PKG)/.PKGINFO
+	@$(PSEUDO) sh -c "cd $(LIBFFI32_PKG) && \
+	                  chown -R root:root . && \
+	                  $(MAKE_PACKAGE) -J --linkadd=yes $(GNUPG_OPTIONS) -m -d .. ."
Index: radix-1.8/libs/libffi/3.4.2-ppc32/PATCHES
===================================================================
Index: radix-1.8/libs/libffi/3.4.2-ppc32/libffi-x32-pkg-description.in
===================================================================
--- radix-1.8/libs/libffi/3.4.2-ppc32/libffi-x32-pkg-description.in	(nonexistent)
+++ radix-1.8/libs/libffi/3.4.2-ppc32/libffi-x32-pkg-description.in	(revision 901)
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.  Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in.  You must
+# make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':'.
+
+          |-----handy-ruler------------------------------------------------------|
+libffi-x32: libffi-x32 @VERSION@ (A Portable Foreign Function Interface Lib)
+libffi-x32:
+libffi-x32: FFI stands for Foreign Function Interface.  A foreign function
+libffi-x32: interface is the popular name for the interface that allows code
+libffi-x32: written in one language to call code written in another language.
+libffi-x32: The libffi library really only provides the lowest, machine
+libffi-x32: dependent layer of a fully featured foreign function interface.
+libffi-x32:
+libffi-x32: Homepage: http://sourceware.org/libffi/
+libffi-x32:
+libffi-x32:
Index: radix-1.8/libs/libffi/3.4.2-ppc32/libffi-x32-pkg-install.sh
===================================================================
--- radix-1.8/libs/libffi/3.4.2-ppc32/libffi-x32-pkg-install.sh	(nonexistent)
+++ radix-1.8/libs/libffi/3.4.2-ppc32/libffi-x32-pkg-install.sh	(revision 901)
@@ -0,0 +1,39 @@
+#!/bin/sh
+
+# arg 1:  the new package version
+pre_install() {
+  /bin/true
+}
+
+# arg 1:  the new package version
+post_install() {
+  /bin/true
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+pre_update() {
+  /bin/true
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+post_update() {
+  post_install
+}
+
+# arg 1:  the old package version
+pre_remove() {
+  /bin/true
+}
+
+# arg 1:  the old package version
+post_remove() {
+  /bin/true
+}
+
+
+operation=$1
+shift
+
+$operation $*

Property changes on: radix-1.8/libs/libffi/3.4.2-ppc32/libffi-x32-pkg-install.sh
___________________________________________________________________
Added: svn:executable
## -0,0 +1 ##
+*
\ No newline at end of property
Index: radix-1.8/libs/libffi/3.4.2-ppc32
===================================================================
--- radix-1.8/libs/libffi/3.4.2-ppc32	(nonexistent)
+++ radix-1.8/libs/libffi/3.4.2-ppc32	(revision 901)

Property changes on: radix-1.8/libs/libffi/3.4.2-ppc32
___________________________________________________________________
Added: svn:ignore
## -0,0 +1,73 ##
+
+# install dir
+dist
+
+# Target build dirs
+.a1x-newlib
+.a2x-newlib
+.at91sam7s-newlib
+
+.build-machine
+
+.a1x-glibc
+.a2x-glibc
+.h3-glibc
+.h5-glibc
+.i586-glibc
+.i686-glibc
+.imx6-glibc
+.jz47xx-glibc
+.makefile
+.am335x-glibc
+.omap543x-glibc
+.p5600-glibc
+.power8-glibc
+.power8le-glibc
+.power9-glibc
+.power9le-glibc
+.m1000-glibc
+.riscv64-glibc
+.rk328x-glibc
+.rk33xx-glibc
+.rk339x-glibc
+.s8xx-glibc
+.s9xx-glibc
+.x86_64-glibc
+
+# Hidden files (each file)
+.makefile
+.dist
+.rootfs
+
+# src & hw requires
+.src_requires
+.src_requires_depend
+.requires
+.requires_depend
+
+# Tarballs
+*.gz
+*.bz2
+*.lz
+*.xz
+*.tgz
+*.txz
+
+# Signatures
+*.asc
+*.sig
+*.sign
+*.sha1sum
+
+# Patches
+*.patch
+
+# Descriptions
+*.dsc
+*.txt
+
+# Default linux config files
+*.defconfig
+
+# backup copies
+*~
Index: radix-1.8/libs/libffi/3.4.2-x86_32/Makefile
===================================================================
--- radix-1.8/libs/libffi/3.4.2-x86_32/Makefile	(nonexistent)
+++ radix-1.8/libs/libffi/3.4.2-x86_32/Makefile	(revision 901)
@@ -0,0 +1,165 @@
+
+COMPONENT_TARGETS  = $(HARDWARE_INTEL_PC64)
+
+NEED_ABS_PATH      = true
+COMPONENT_IS_3PP   = true
+
+CREATE_X86_32_PACKAGE = true
+
+
+include ../../../build-system/constants.mk
+
+
+SOURCE_REQUIRES    = sources/packages/l/libffi
+
+REQUIRES           = libs/libffi/3.4.2
+REQUIRES          += libs/glibc/2.34-x86_32
+
+# ======= __END_OF_REQUIRES__ =======
+
+
+version            = 3.4.2
+tar_gz_archive     = $(SRC_PACKAGE_PATH)/packages/l/libffi/libffi-$(version).tar.gz
+SRC_ARCHIVE        = $(tar_gz_archive)
+SRC_DIR            = $(TARGET_BUILD_DIR)/libffi-$(version)
+src_dir_name       = libffi-$(version)
+src_done           = $(TARGET_BUILD_DIR)/.source_done
+
+PATCHES = PATCHES
+
+build_dir          = $(TARGET_BUILD_DIR)/build
+build_target       = $(TARGET_BUILD_DIR)/.build_done
+install_target     = $(TARGET_BUILD_DIR)/.install_done
+
+
+####### Targets
+
+PKG_GROUP = libs
+#
+# *PKG_NAME & *PKG_VERSION shouldn't be a reference to value.
+#
+LIBFFI32_PKG_NAME                = libffi-x32
+LIBFFI32_PKG_VERSION             = 3.4.2
+LIBFFI32_PKG_ARCH                = $(TOOLCHAIN)
+LIBFFI32_PKG_DISTRO_NAME         = $(DISTRO_NAME)
+LIBFFI32_PKG_DISTRO_VERSION      = $(DISTRO_VERSION)
+LIBFFI32_PKG_GROUP               = $(PKG_GROUP)
+###                               |---handy-ruler-------------------------------|
+LIBFFI32_PKG_SHORT_DESCRIPTION   = Portable Foreign Function Interface Library
+LIBFFI32_PKG_URL                 = $(BUG_URL)
+LIBFFI32_PKG_LICENSE             = GPLv2
+LIBFFI32_PKG_DESCRIPTION_FILE    = $(TARGET_BUILD_DIR)/$(LIBFFI32_PKG_NAME)-pkg-description
+LIBFFI32_PKG_DESCRIPTION_FILE_IN = $(LIBFFI32_PKG_NAME)-pkg-description.in
+LIBFFI32_PKG_INSTALL_SCRIPT      = $(LIBFFI32_PKG_NAME)-pkg-install.sh
+
+LIBFFI32_PKG     = $(CURDIR)/$(TARGET_BUILD_DIR)/$(LIBFFI32_PKG_NAME)-package
+
+pkg_basename     = $(LIBFFI32_PKG_NAME)-$(LIBFFI32_PKG_VERSION)-$(LIBFFI32_PKG_ARCH)-$(LIBFFI32_PKG_DISTRO_NAME)-$(LIBFFI32_PKG_DISTRO_VERSION)
+
+pkg_archive      = $(TARGET_BUILD_DIR)/$(PKG_GROUP)/$(pkg_basename).$(pkg_arch_suffix)
+pkg_certificate  = $(call cert-name,$(pkg_archive))
+pkg_signature    = $(call sign-name,$(pkg_archive))
+pkg_description  = $(call desc-name,$(pkg_archive))
+products         = $(call pkg-files,$(pkg_archive))
+
+BUILD_TARGETS    = $(build_target)
+BUILD_TARGETS   += $(install_target)
+
+PRODUCT_TARGETS  = $(products)
+
+ROOTFS_TARGETS   = $(pkg_archive)
+
+
+include ../../../build-system/core.mk
+
+
+env_sysroot  = DESTDIR=$(LIBFFI32_PKG)
+
+
+extra_configure_switches  = --libdir=/usr/lib$(MULTILIB_X86_32_SUFFIX)
+extra_configure_switches += --docdir=/usr/share/doc/$(src_dir_name)
+extra_configure_switches += --mandir=/usr/share/man
+extra_configure_switches += --disable-dependency-tracking
+extra_configure_switches += --sysconfdir=/etc
+extra_configure_switches += --localstatedir=/var
+ifeq ($(__ENABLE_STATIC__),yes)
+extra_configure_switches += --enable-static=yes
+else
+extra_configure_switches += --enable-static=no
+endif
+extra_configure_switches += --enable-shared=yes
+
+
+####### Dependencies
+
+$(src_done): $(SRC_ARCHIVE) $(PATCHES_DEP)
+	$(UNPACK_SRC_ARCHIVE)
+	$(APPLY_PATCHES)
+	@( cd $(SRC_DIR) ; ./autogen.sh )
+	@touch $@
+
+$(build_target): $(src_done)
+	@mkdir -p $(build_dir)
+	@cd $(build_dir) && $(BUILD_ENVIRONMENT) ../$(src_dir_name)/configure \
+	  --prefix=/usr               \
+	  --build=$(BUILD)            \
+	  --host=$(TARGET32)          \
+	  $(extra_configure_switches)
+	@cd $(build_dir) && $(BUILD_ENVIRONMENT) $(MAKE)
+	@touch $@
+
+$(install_target): $(build_target)
+	@mkdir -p $(LIBFFI32_PKG)
+	@cd $(build_dir) && $(BUILD_ENVIRONMENT) $(MAKE) -j1 install $(env_sysroot)
+	@rm -rf $(LIBFFI32_PKG)/usr/include
+	@rm -rf $(LIBFFI32_PKG)/usr/share
+	# ======= remove toolchain path from target libtool *.la files =======
+	@( cd $(LIBFFI32_PKG)/usr/lib$(MULTILIB_X86_32_SUFFIX) ; \
+	   sed -i "s,$(TARGET_DEST_DIR),,g" libffi.la  \
+	 )
+	# ======= Install the same to $(TARGET_DEST_DIR) =======
+	$(call install-into-devenv, $(LIBFFI32_PKG))
+	# ======= tune libtool *.la search path to the target destination for development =======
+	@( cd $(TARGET_DEST_DIR)/usr/lib$(MULTILIB_X86_32_SUFFIX) ; \
+	   sed -i "s,/usr,$(TARGET_DEST_DIR)/usr,g" libffi.la ; \
+	   sed -i "s,L/lib,L$(TARGET_DEST_DIR)/lib,g" libffi.la \
+	 )
+	# ======= tune pkg-config *.pc search path to the target destination for development =======
+	@( cd $(TARGET_DEST_DIR)/usr/lib$(MULTILIB_X86_32_SUFFIX)/pkgconfig ; \
+	   sed -i "s,/usr,$(TARGET_DEST_DIR)/usr,g" libffi.pc \
+	 )
+	# ======= Strip binaries =======
+	@( cd $(LIBFFI32_PKG) ; \
+	   find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs $(STRIP) --strip-unneeded 2> /dev/null ; \
+	   find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs $(STRIP) --strip-unneeded 2> /dev/null ; \
+	 )
+ifeq ($(__ENABLE_STATIC__),yes)
+	@( cd $(LIBFFI32_PKG) ; \
+	   find . | xargs file | grep "current ar archive" | cut -f 1 -d : | xargs $(STRIP) -g 2> /dev/null ; \
+	 )
+endif
+	@touch $@
+
+$(LIBFFI32_PKG_DESCRIPTION_FILE): $(LIBFFI32_PKG_DESCRIPTION_FILE_IN)
+	@cat $< | $(SED) -e "s/@VERSION@/$(version)/g" > $@
+
+$(pkg_certificate) : $(pkg_archive) ;
+$(pkg_signature)   : $(pkg_archive) ;
+$(pkg_description) : $(pkg_archive) ;
+
+$(pkg_archive): $(install_target) $(LIBFFI32_PKG_DESCRIPTION_FILE) $(LIBFFI32_PKG_INSTALL_SCRIPT)
+	@cp $(LIBFFI32_PKG_DESCRIPTION_FILE) $(LIBFFI32_PKG)/.DESCRIPTION
+	@cp $(LIBFFI32_PKG_INSTALL_SCRIPT) $(LIBFFI32_PKG)/.INSTALL
+	@$(BUILD_PKG_REQUIRES) $(LIBFFI32_PKG)/.REQUIRES
+	@echo "pkgname=$(LIBFFI32_PKG_NAME)"                            >  $(LIBFFI32_PKG)/.PKGINFO ; \
+	 echo "pkgver=$(LIBFFI32_PKG_VERSION)"                          >> $(LIBFFI32_PKG)/.PKGINFO ; \
+	 echo "arch=$(LIBFFI32_PKG_ARCH)"                               >> $(LIBFFI32_PKG)/.PKGINFO ; \
+	 echo "distroname=$(LIBFFI32_PKG_DISTRO_NAME)"                  >> $(LIBFFI32_PKG)/.PKGINFO ; \
+	 echo "distrover=$(LIBFFI32_PKG_DISTRO_VERSION)"                >> $(LIBFFI32_PKG)/.PKGINFO ; \
+	 echo "group=$(LIBFFI32_PKG_GROUP)"                             >> $(LIBFFI32_PKG)/.PKGINFO ; \
+	 echo "short_description=\"$(LIBFFI32_PKG_SHORT_DESCRIPTION)\"" >> $(LIBFFI32_PKG)/.PKGINFO ; \
+	 echo "url=$(LIBFFI32_PKG_URL)"                                 >> $(LIBFFI32_PKG)/.PKGINFO ; \
+	 echo "license=$(LIBFFI32_PKG_LICENSE)"                         >> $(LIBFFI32_PKG)/.PKGINFO
+	@$(PSEUDO) sh -c "cd $(LIBFFI32_PKG) && \
+	                  chown -R root:root . && \
+	                  $(MAKE_PACKAGE) -J --linkadd=yes $(GNUPG_OPTIONS) -m -d .. ."
Index: radix-1.8/libs/libffi/3.4.2-x86_32/PATCHES
===================================================================
Index: radix-1.8/libs/libffi/3.4.2-x86_32/libffi-x32-pkg-description.in
===================================================================
--- radix-1.8/libs/libffi/3.4.2-x86_32/libffi-x32-pkg-description.in	(nonexistent)
+++ radix-1.8/libs/libffi/3.4.2-x86_32/libffi-x32-pkg-description.in	(revision 901)
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.  Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in.  You must
+# make exactly 11 lines for the formatting to be correct.  It's also
+# customary to leave one space after the ':'.
+
+          |-----handy-ruler------------------------------------------------------|
+libffi-x32: libffi-x32 @VERSION@ (A Portable Foreign Function Interface Lib)
+libffi-x32:
+libffi-x32: FFI stands for Foreign Function Interface.  A foreign function
+libffi-x32: interface is the popular name for the interface that allows code
+libffi-x32: written in one language to call code written in another language.
+libffi-x32: The libffi library really only provides the lowest, machine
+libffi-x32: dependent layer of a fully featured foreign function interface.
+libffi-x32:
+libffi-x32: Homepage: http://sourceware.org/libffi/
+libffi-x32:
+libffi-x32:
Index: radix-1.8/libs/libffi/3.4.2-x86_32/libffi-x32-pkg-install.sh
===================================================================
--- radix-1.8/libs/libffi/3.4.2-x86_32/libffi-x32-pkg-install.sh	(nonexistent)
+++ radix-1.8/libs/libffi/3.4.2-x86_32/libffi-x32-pkg-install.sh	(revision 901)
@@ -0,0 +1,39 @@
+#!/bin/sh
+
+# arg 1:  the new package version
+pre_install() {
+  /bin/true
+}
+
+# arg 1:  the new package version
+post_install() {
+  /bin/true
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+pre_update() {
+  /bin/true
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+post_update() {
+  post_install
+}
+
+# arg 1:  the old package version
+pre_remove() {
+  /bin/true
+}
+
+# arg 1:  the old package version
+post_remove() {
+  /bin/true
+}
+
+
+operation=$1
+shift
+
+$operation $*

Property changes on: radix-1.8/libs/libffi/3.4.2-x86_32/libffi-x32-pkg-install.sh
___________________________________________________________________
Added: svn:executable
## -0,0 +1 ##
+*
\ No newline at end of property
Index: radix-1.8/libs/libffi/3.4.2-x86_32
===================================================================
--- radix-1.8/libs/libffi/3.4.2-x86_32	(nonexistent)
+++ radix-1.8/libs/libffi/3.4.2-x86_32	(revision 901)

Property changes on: radix-1.8/libs/libffi/3.4.2-x86_32
___________________________________________________________________
Added: svn:ignore
## -0,0 +1,73 ##
+
+# install dir
+dist
+
+# Target build dirs
+.a1x-newlib
+.a2x-newlib
+.at91sam7s-newlib
+
+.build-machine
+
+.a1x-glibc
+.a2x-glibc
+.h3-glibc
+.h5-glibc
+.i586-glibc
+.i686-glibc
+.imx6-glibc
+.jz47xx-glibc
+.makefile
+.am335x-glibc
+.omap543x-glibc
+.p5600-glibc
+.power8-glibc
+.power8le-glibc
+.power9-glibc
+.power9le-glibc
+.m1000-glibc
+.riscv64-glibc
+.rk328x-glibc
+.rk33xx-glibc
+.rk339x-glibc
+.s8xx-glibc
+.s9xx-glibc
+.x86_64-glibc
+
+# Hidden files (each file)
+.makefile
+.dist
+.rootfs
+
+# src & hw requires
+.src_requires
+.src_requires_depend
+.requires
+.requires_depend
+
+# Tarballs
+*.gz
+*.bz2
+*.lz
+*.xz
+*.tgz
+*.txz
+
+# Signatures
+*.asc
+*.sig
+*.sign
+*.sha1sum
+
+# Patches
+*.patch
+
+# Descriptions
+*.dsc
+*.txt
+
+# Default linux config files
+*.defconfig
+
+# backup copies
+*~
Index: radix-1.8/net/p11-kit/0.23.22/Makefile
===================================================================
--- radix-1.8/net/p11-kit/0.23.22/Makefile	(revision 900)
+++ radix-1.8/net/p11-kit/0.23.22/Makefile	(revision 901)
@@ -54,7 +54,7 @@
 
 SOURCE_REQUIRES    = sources/packages/n/p11-kit
 
-REQUIRES           = libs/libffi/3.3
+REQUIRES           = libs/libffi/3.4.2
 REQUIRES          += libs/libtasn1/4.16.0
 
 # ======= __END_OF_REQUIRES__ =======
Index: radix-1.8/net/p11-kit/0.23.22-ppc32/Makefile
===================================================================
--- radix-1.8/net/p11-kit/0.23.22-ppc32/Makefile	(revision 900)
+++ radix-1.8/net/p11-kit/0.23.22-ppc32/Makefile	(revision 901)
@@ -16,7 +16,7 @@
 SOURCE_REQUIRES    = sources/packages/n/p11-kit
 
 REQUIRES           = net/p11-kit/0.23.22
-REQUIRES          += libs/libffi/3.3-ppc32
+REQUIRES          += libs/libffi/3.4.2-ppc32
 REQUIRES          += libs/libtasn1/4.16.0-ppc32
 
 # ======= __END_OF_REQUIRES__ =======
Index: radix-1.8/net/p11-kit/0.23.22-x86_32/Makefile
===================================================================
--- radix-1.8/net/p11-kit/0.23.22-x86_32/Makefile	(revision 900)
+++ radix-1.8/net/p11-kit/0.23.22-x86_32/Makefile	(revision 901)
@@ -13,7 +13,7 @@
 SOURCE_REQUIRES    = sources/packages/n/p11-kit
 
 REQUIRES           = net/p11-kit/0.23.22
-REQUIRES          += libs/libffi/3.3-x86_32
+REQUIRES          += libs/libffi/3.4.2-x86_32
 REQUIRES          += libs/libtasn1/4.16.0-x86_32
 
 # ======= __END_OF_REQUIRES__ =======
Index: radix-1.8/products/base/Makefile
===================================================================
--- radix-1.8/products/base/Makefile	(revision 900)
+++ radix-1.8/products/base/Makefile	(revision 901)
@@ -114,9 +114,9 @@
 #             │   ├── app/xz/5.2.5-ppc32          └── app/kmod/27                │
 #             │   └── app/xz/5.2.5-x86_32             ├── app/kmod/27-ppc32      │
 #             │                                       └── app/kmod/27-x86_32     │
-#             ├── libs/libffi/3.3                                                │
-#             │   ├── libs/libffi/3.3-ppc32                                      │
-#             │   └── libs/libffi/3.3-x86_32                                     │
+#             ├── libs/libffi/3.4.2                                                │
+#             │   ├── libs/libffi/3.4.2-ppc32                                      │
+#             │   └── libs/libffi/3.4.2-x86_32                                     │
 #             │                                                                  │
 #             ├── libs/lzo/2.10                                                  │
 #             │   ├── libs/lzo/2.10-ppc32                                        │
@@ -295,7 +295,7 @@
 #             │      ...
 #             │       ├───────────────────────────────────┬── libs/zlib/1.2.11
 #             │       │                                   ├── app/xz/5.2.5
-#             │       ├── dev/python2/2.7.18              ├── libs/libffi/3.3
+#             │       ├── dev/python2/2.7.18              ├── libs/libffi/3.4.2
 #             │       │   ├── dev/python2/2.7.18-ppc32    ├── libs/readline/8.1
 #             │       │   └── dev/python2/2.7.18-x86_32   ├── libs/expat/2.2.10
 #             │       │                                   └── net/openssl/1.1.1l
Index: radix-1.8/sources/packages/l/libffi/Makefile
===================================================================
--- radix-1.8/sources/packages/l/libffi/Makefile	(revision 900)
+++ radix-1.8/sources/packages/l/libffi/Makefile	(revision 901)
@@ -7,9 +7,9 @@
 
 url         = $(DOWNLOAD_SERVER)/sources/packages/l/libffi
 
-versions    = 3.3
+versions    = 3.4.2
 pkgname     = libffi
-suffix      = tar.gz
+suffix      = tar.xz
 
 tarballs    = $(addsuffix .$(suffix), $(addprefix $(pkgname)-, $(versions)))
 sha1s       = $(addsuffix .sha1sum, $(tarballs))